Surligner plusieurs lignes identiques comportant plusieurs colonnes

lizanne828

XLDnaute Nouveau
Bonjour,

Je pensais que mon problème était simple, et pourtant je tourne en rond!
J'ai une importation de plusieurs centaines de lignes excel sur une 15 aine de colonnes.
Je voudrais trouver un code qui va me surligner toutes les lignes identiques (c'est à dire dont les données sont identiques sur TOUTES les colonnes).

Si quelqu'un a une idée??

Merci!
 

CISCO

XLDnaute Barbatruc
Re : Surligner plusieurs lignes identiques comportant plusieurs colonnes

Bonjour

C'est faisable avec une MFC mais cela le serait encore plus si tu nous fournissais un petit fichier en pièce jointe.

@plus
 

lizanne828

XLDnaute Nouveau
Re : Surligner plusieurs lignes identiques comportant plusieurs colonnes

doublons excel....jpg

En gros je voudrais que le surlignage soit automatique, et au lieu de 3 colonnes, j'ai 15 colonnes (donc pas de bidouillage possible avec concatener dans une colonne supplémentaire et comptage du nombre de cellules identiques...)
 

Fichiers joints

phlaurent55

XLDnaute Barbatruc
Re : Surligner plusieurs lignes identiques comportant plusieurs colonnes

Bonjour à tous,

un essai en pièce jointe

à+

Philippe
 

Fichiers joints

lizanne828

XLDnaute Nouveau
Re : Surligner plusieurs lignes identiques comportant plusieurs colonnes

Laurent, j'ai utilisé ta méthode, je te remercie ça fonctionne. Au début je voulais éviter une solution avec Concatener car j'ai beaucoup de colonnes, mais en fait ça passe, ce n'est pas embêtant.
Merci!

Cisco, je n'ai pas trouvé la macro? il y avait une macro?

En tous cas merci à vous pour votre aide!
 

CISCO

XLDnaute Barbatruc
Re : Surligner plusieurs lignes identiques comportant plusieurs colonnes

Bonjour
Cisco, je n'ai pas trouvé la macro? il y avait une macro?
Il ni a pas de macro. Cf. plutôt dans les mises en forme conditionnelles, dans l'onglet "Accueil", la formule
Code:
=SOMME(($A$2:$A$70&$B$2:$B$70&$C$2:$C$70&$D$2:$D$70&$E$2:$E$70&$F$2:$F$70&$G$2:$G$70&$H$2:$H$70=$A2&$B2&$C2&$D2&$E2&$F2&$G2&$H2)*1)>1
J'ai mis 70 mais tu peux mettre un autre nombre.

@plus
 

lizanne828

XLDnaute Nouveau
Re : Surligner plusieurs lignes identiques comportant plusieurs colonnes

Ok!

Effectivement je vois mieux. Du coup on arrive au même résultat.
La longueur d'une formule avec ce type de solution me faisait peur sur 15 colonnes. C'est vrai que ça fait une formule à rallonge du coup, mais ça marche!

Merci pour ton aide!
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas