Statistiques nombre de travaux réalisés Jour et répartition par heure...

laitfraise

XLDnaute Nouveau
Bonjour/soir à tous,

J'essaie de réaliser un tableau qui me permettrait, sur une plage horaire de 8h à 2h du matin, comportant différentes plages horaires 8h-10h, 10h12, etc, de quantifier le nombre de tâches demandées et je m'emmèle les pinceaux par rapport à ceci : je ne sais pas si je dois faire commencer les plages horaires faire un 8h-10 et 10h-12h ou
faire un 8h-10 et 11h-12h, ou
faire un 8h-9h59 et 10h-11h59, ou
faire un 8h-10h et 10h01-12h

voici les formules sur lesquelles je me pose la question à savoir laquelle utiliser :
=NB(C3:C103)-NB.SI(C3:C103;"<8:00")-NB.SI(C3:C103;">11:00") etc..

ou

=NB(C3:C103)-NB.SI(C3:C103;"<8:00")-NB.SI(C3:C103;">10:59") etc..

ou

=NB(C3:C103)-NB.SI(C3:C103;"<8:00")-NB.SI(C3:C103;">11:00") et

=NB(C3:C103)-NB.SI(C3:C103;"<11:01")-NB.SI(C3:C103;">13:00"), etc...

ou

=NB(C3:C103)-NB.SI(C3:C103;"<8:00")-NB.SI(C3:C103;">11:00") et

=NB(C3:C103)-NB.SI(C3:C103;"<12:00")-NB.SI(C3:C103;">13:00")

si quelqu'un pouvait m'aider, ce serait formidable
merci d'avance
dinah
 

Pièces jointes

  • Stats travaux demandés.xls
    35 KB · Affichages: 67

Gael

XLDnaute Barbatruc
Re : Statistiques nombre de travaux réalisés Jour et répartition par heure...

Bonjour Laitfraise,

Ci-joint ton fichier modifié. J'ai préféré utiliser des formules de type Sommeprod. La comparaison avec des fractions est plus pratique lorsqu'on travaille avec des heures (1h=1/24).

tu peux modifier les bornes des intervalles en changeant les >= en >.

Pour le mois, j'ai mis une date au lieu de Février (01/02/08) en format mmmm pour n'afficher que le mois ce qui permet de comparer directement avec le n° du mois.

@+

Gael
 

Pièces jointes

  • Stats_V1.xls
    35 KB · Affichages: 72

laitfraise

XLDnaute Nouveau
Bonjour
Gael
Merci pour ta réponse rapide.
Je vais paraître ingrate, mais n'aurais tu pas autre chose .... de plus simple ?
Ne connaissant pas cette formule et son application, j'ai bien peur de ne pouvoir ni l'intellectualiser, ni la reproduire : dans un premier temps et au niveau logique, peux tu me dire concernant les horaires suivants quel est le modèle qui s'applique pour le type de calcul statistiques:
A/ 8h-10h et 10h-12h
B/ 8h-10h et 11h-12h, ou
C/ 8h-9h59 et 10h-11h59, ou
D/ 8h-10h et 10h01-12h
Mille mercis
Dinah
 

Tibo

XLDnaute Barbatruc
Re : Statistiques nombre de travaux réalisés Jour et répartition par heure...

Bonjour laitfraise,

La fonction SOMMEPROD correspond ici à un SOMME.SI avec multi-critères

Peut-être une simplification pour la rendre plus lisible :

en G4 :

Code:
=SOMMEPROD(((MOIS(B2:B103)=2)*(C2:C103[COLOR=blue]>="8:00"*1[/COLOR])*(C2:C103<[COLOR=blue]"10:00"*1[/COLOR])))

Dans la formule initiale proposée par Gael, les fractions représentent des fractions de journée. Car pour Excel, 24 heures équivaut à 1, donc 8h00 équivaut à 8/24 ou 1/3

N'hésite pas à découvrir cette fonction SOMMEPROD qui est très puissante.

@+
 

laitfraise

XLDnaute Nouveau
Re : Statistiques nombre de travaux réalisés Jour et répartition par heure...

merci Tibo

Ok, je comprends mieux avec la transformation des fractions en heures,
si j'applique cette formule pour la seconde tranche horaire ce sera donc :

=SOMMEPROD(((MOIS(B2:B103)=2)*(C2:C103>="11:00"*1)*(C2:C103<"12:00"*1)))
ou bien
=SOMMEPROD(((MOIS(B2:B103)=2)*(C2:C103>="10:00"*1)*(C2:C103<"12:00"*1)))
ou bien
=SOMMEPROD(((MOIS(B2:B103)=2)*(C2:C103>="10:00"*1)*(C2:C103<"11:59"*1)))
ou bien
=SOMMEPROD(((MOIS(B2:B103)=2)*(C2:C103>="10:01"*1)*(C2:C103<"12:00"*1)))dans la formule le *1 correspond à quoi stp ?

ReMerci
dinah
__________________
 

Tibo

XLDnaute Barbatruc
Re : Statistiques nombre de travaux réalisés Jour et répartition par heure...

re,

Le fait de mettre les heures entre guillemets les transforme en Texte.

Or Excel ne sait pas vraiment faire de calcul avec du Texte. Le *1 permet de rendre numérique une valeur entre guillemets et de faire ensuite des calculs (sous réserve que la valeur entre guillemets soit numérique)

L'avantage principal (pour ne pas dire unique) de cette méthode est la lecture plus facile de la formule.

@+
 
Haut Bas