soustraction conditionnelle si case non vide

incubus

XLDnaute Nouveau
Bonjour.

J'ai un soucis de formule.
Je dois soustraire 2 cases (A1-B1) et indiquer le résultat dans C1.
Le soucis c'est que si A1 et B1 sont vides, C1 indique zéro; Hors je voudrais que le résultat en C1 n'affiche un résultat que si A1 et B1 ne sont pas vides, sinon, il n'affiche rien.
Mais je ne trouve pas comment rédiger cette condition ! :(
 

Staple1600

XLDnaute Barbatruc
Bonjour le fil, le forum, incubus, M12, pierrejean

Une autre formule
(au cas où on aurait l'idée farfelue de saisir du texte en A1 et B1)
=SI(NB(A1:B1)=0;"";SIERREUR(A1-B1;""))
 

job75

XLDnaute Barbatruc
Bonjour incubus, M12, pierrejean, JM,

En C1 =A1-B1 ou si l'on préfère =N(A1)-N(B1)

Avec C1 au format personnalisé Standard;-Standard; pour masquer la valeur zéro.

A+
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas