XL 2016 Soucis sur le résultat d'une date.

BALANCIE

XLDnaute Nouveau
Bonjour,

Il ya quelques jours , j'ai demandé une solution concernant un soucis avec les dates.
J'ai eu plusieurs solutions donc celles de @+ Lolote83 et de zebanx, qui m'ont convenues parfaitement.

En partant du fichier test de "zebanx".
La demande était lorsque je tape simplement les 2 chiffres 10 dans une cellule,j'obtiens dans une autre cellule la date complète dans la feuille par ex.du mois de Mars j'ai dans ce cas, 10/03/2018.
Cela marche, mais lorsque j'utilise un "collé spécial avec liasion", là aussi cela fonctionne, mais... si j'efface (où mis 0)les 2 chiffres dans cellule où j'ai tapé, je n'obtiens dans la cellule Date(jour)non pas une cellule vide mais une cellule remplie avec une date éronnée type 31/12.
Comment régler ce problème.

Voiçi le code donné par :

@+ Lolote83 ( travaillant directement sur la feuille du mois)

=SI(ESTVIDE(B6);0;DATE(ND_Date;$C$2;B6))

zebanx (travaillant en reference de la feuille PARAMETRES).

=SIERREUR(SI(C4="";"";DATE(ANNEE(AUJOURDHUI());RECHERCHEV($A$1;PARAMETRES!$G$4:$H$15;2;0);C4));"")

Merci à vous.
Daryl.B
 

Fichiers joints

BALANCIE

XLDnaute Nouveau
Bonjour Bebere ,

Merci pour solution (si simple & logique), elle me convient parfaitement et met ce sujet comme Résolu.
Merci encore à vous tous.

Daryl.B :)
 

Discussions similaires


Haut Bas