soucis avec fonction sur excel

Franck123

XLDnaute Nouveau
Bonjour,

j'ai fait un planning par semaine avec plusieurs activitees,ce fichier va etre mis sur intranet et je ne pas qu il soit trop lourd ,j'avais mis les formules par semaines et le fichiers etait trop volumineux ,j'aimerai que quelqu un puisse m'aider pour mettre les formules du style =nb.si(cell;"perm") en recherchant par date dans les onglet semaine

merci de votre aide
 

Fichiers joints

BrunoM45

XLDnaute Barbatruc
Re : soucis avec fonction sur excel

Bonjour Franck123,

Tu trouveras ci-joint un premier jet avec un peu de VBA ;)
Reste à corriger si le même jour, la même tache pour plusieurs personnes

A+
 

Fichiers joints

Monique

XLDnaute Barbatruc
Re : soucis avec fonction sur excel

Bonjour,

Jours colonne B calculés selon le n° de semaine de la colonne A
Colonne A : même nom que les onglets (S42 S43 S44 etc.)

Pour avoir dans le tableau le nb d'activités par jour :
Indirect() pour tomber sur la bonne feuille
et SommeProd

=SI(ESTERR(INDIRECT($A2&"!A1"));"";SOMMEPROD((INDIRECT($A2&"!B2:F2")=$B2)*(INDIRECT($A2&"!B3:F22")=C$1)))

(je n'ai fait que les 3 premières colonnes
et je ne sais pas si j'ai compris)
 

Fichiers joints

Franck123

XLDnaute Nouveau
Re : soucis avec fonction sur excel

Bonjour Franck123,

Tu trouveras ci-joint un premier jet avec un peu de VBA ;)
Reste à corriger si le même jour, la même tache pour plusieurs personnes

A+
Bonjour Bruno,
j'aimerai savoir comment tu as fait et comprendre ,il y a 2 macro ,une qui fait un ras et l'autre ?
pour le code ,il me faudrait qu'un total dans le tableau de charge et pas le nom ex;si dupond1 fait 3 heure de "perm" et dupont 2 fait 2 heures de "perm" le 22/10 il faudrait 5 sur le tableau de charge à "perm" le 22/10.
de mon cote j'ai travaille par formule :
NB.SI('Semaine 42'!lundi;TB!C2), lundi est une BD ,C2 =>activite "perm"
mais la recopie des formules est longue ta methode irai beaucoup mieux en sachant que je creer ce planning toutes les semaines .

merci pour ton aide

PS :Merci Monique
 

BrunoM45

XLDnaute Barbatruc
Re : soucis avec fonction sur excel

Salut Franck123,

Le problème, c'est que dans ton fichier d'origine il n'y a aucune heure de marquée !?
Comment faire alors ...

A+
 

Franck123

XLDnaute Nouveau
Re : soucis avec fonction sur excel

Salut Franck123,

Le problème, c'est que dans ton fichier d'origine il n'y a aucune heure de marquée !?
Comment faire alors ...

A+
Bonjour,

la feuille Semaine 42 est celle du fichier d'origine ,il me faudrait simplement le nbre total heures sur la journee du 1/11 pour une activite (ex:pERM)
merci encore
 

Fichiers joints

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas