Sommes par rapport à une date

si_sial

XLDnaute Nouveau
Bonjour à tous,

Je travail actuellement sur un tableau qui recense mes commandes fournisseurs, la date de livraison, la date de facturation (formule fin de mois par rapport à la livraison) ainsi que le montant de la commande.

J'ai recensé toutes mes commandes arrivant à échéance en février, mars, avril... le but étant de faire un sous total automatique par mois. Mais voila je ne sais pas quelle formule pourrait faire la somme de la colone "montant" en triant d'abord la colone précédente "date".

Pouvez-vous m'aider je souhaite que sur mon tableau je puisse recenser environ 3-4 mois de commande et avoir des totaux par mois sans etre obligé de trier mes données avant, pouvoir faire de la saisie au fur et à mesure sans se soucier des dates...

En vous remerciant pour vous aide
 

simraill

XLDnaute Occasionnel
Re : Sommes par rapport à une date

Bonjour si_sial,
Un fichier avec ton tableau serait utile à comprendre l'organisation de tes données ;)

Simraill
 

Modeste

XLDnaute Barbatruc
Re : Sommes par rapport à une date

Bonjour si_sial, sois le bienvenu ou la bienvenue,

Dans un cas comme celui-ci, soit tu décris minutieusement la manière dont sont structurées les informations, soit (et c'est souvent mieux) tu joins un extrait de ton fichier, en veillant à en supprimer les données à caractère confidentiel.
Comment pourrions-nous proposer une solution, autrement? Ou alors, tu essaies de voir par toi-même, du côté des fonctions SOMME.SI ou SOMMEPROD

Oups! Bonjour Simraill
 

si_sial

XLDnaute Nouveau
Re : Sommes par rapport à une date

Merci à vous j'ai mis mon doc en PJ.

Cependant EXCFL à trouvé un solution. J'ai compris comment faire une liste déroulante mais je ne sais pas comment tu as fait pour que les résultats du dessous apparaissent.
 

Fichiers joints

Modeste

XLDnaute Barbatruc
Re : Sommes par rapport à une date

Re-bonjour,

Un essai avec SOMMEPROD en F7:
Code:
=SOMMEPROD((MOIS($D$5:$D$17)=MOIS(1&F6))*($E$5:$E$17))
... à copier-coller, ensuite en F10 et F13
 

si_sial

XLDnaute Nouveau
Re : Sommes par rapport à une date

Merci beaucoup problème résolu je ne pensais pas avoir de l'aide et une réponse aussi rapidement !
 

Discussions similaires


Haut Bas