XL 2013 Sommeprod : nb de valeurs dates et excluant le texte

levana

XLDnaute Junior
Bonjour à tous,

Pourriez vous m'aider sur le fichier joint? Je cherche à dénombrer le nombre de dates selon l'année (2014, 2015...) en excluant le texte NA ou Refus?

Milles merci d'avance
 

Fichiers joints

Chris24

XLDnaute Impliqué
Supporter XLD
Bonjour

Une T'it fonction sommeprod matricielle

Code:
={SOMME(SI(ESTNUM($B2:$B21);1*(ANNEE($B2:$B21)=C1)))}
Cdt
 

levana

XLDnaute Junior
Merci Chris,
La formule ne renvoie pas la valeur correcte.
Elle me renvoie 1, alors que j'ai 9 valeurs en 2014?
Est ce que tu peux m'aider?
Merci encore
 

Chris24

XLDnaute Impliqué
Supporter XLD
RE

Formule matricielle, ne pas saisir les accolades

Il faut valider la formule avec CtRl+Maj+Enter

Cdt
 

Jocelyn

XLDnaute Barbatruc
Bonjour le Forum,
Bonjour levana, chris24,

Pour le fun si tu veux le faire avec le sommeprod tu peux écrire la formule de cette façon (sans validation matricielle)

Code:
=SOMMEPROD((DROITE(TEXTE(B2:B21;"jj/mm/aaaa");2)="14")*1)
ou

Code:
=SOMMEPROD((DROITE(TEXTE($B$2:$B$21;"jj/mm/aaaa");2)=DROITE(C1;2))*1)
qui te permet d'étirer vers la droite sans modifier le "14" par "15"

Cordialement
 

levana

XLDnaute Junior
Merci le forum. La formule Sommeprod de Jocelyn fonctionne, celle de Somme.si, je n'y suis pas arrivé.
 

Discussions similaires


Haut Bas