Résolu XL 2019 Somme si ens et sous total

Abby003

XLDnaute Nouveau
Bonjour à tous,

Je suis à la recherche d'une fonction permettant de lier les fonction somme si ens et sous total.

Dans un premier temps j'ai appliqué la formule suivante:
=SOMME.SI.ENS(TableauTotal!$A$6:$A$118;TableauTotal!$D$6:$D$118;$C$4;TableauTotal!$B$6:$B$118;D3)

Ayant fait évoluer mon tableau et notamment appliquer des masques à un certain nombre de ligne, j'aimerais réaliser la même formule en excluant les lignes masqués.
Cela est-il possible selon vous?

J'ai vue que la formule sommeprod pouvais si prêter mais je n'arrive pas à l'appliquer à mon tableau.

Votre aide me serait d'un grand recours.

Je vous remercie par avance pour votre aide et conseils.

Cordialement

ABBY
 
Ce fil a été résolu! Aller à la solution…

Fichiers joints

micheldu52

XLDnaute Occasionnel
Bonjour,
Essaye, plutôt que de les masquer, de les filtrer.
Tu ajoutes une autre colonnes avec que des valeurs 1 et tu l'intègres dans ton somme.si.ens avec 1 comme condition
Ensuite tu mets un 0 dans cette colonne pour les lignes que tu veux masquer et tu filtres sur uniquement les 1
Cela aura deux conséquences :
1) tu ne verras plus les lignes (ce qui est visuellement la même chose que si tu les masques)
2) elles ne seront plus prise en compte par ta formule
et le tour est joué!
Bien cordialement,
Michel
 
Ce message a été identifié comme étant une solution!

Abby003

XLDnaute Nouveau
Je te remercie pour cette réponse.
SI d'autres personnes ont des idées je suis preneuse.

Que devient la formule pour ajouter cette condition?
Où placer la condition dans la formule?

Cela est-il applicable pour un tableau croisé dynamique?
 

micheldu52

XLDnaute Occasionnel
Explique pourquoi 785 ne marche pas, pour moi cela doit faire 110+675 donc bien 785
1110FRGR0342EOH>50cm
1675FRGR0342EOH>50cm
 

Abby003

XLDnaute Nouveau
Ha merci tu m'as débloqué !
En faite, la ligne 111/FRGR0342/EOH>50cm était caché par un filtre dans mon tableau. C'est pour ça que je ne comprenais pas.

Merci pour ton aide.

Penses-tu que la méthode appliquée peut s'adapter dans un tableau croisé dynamique?
Le tableau croisé dynamique est déjà créé, mais prend en compte la totalité des lignes. Or je ne voudrais prendre seulement que les lignes où il y a un 1.
 

micheldu52

XLDnaute Occasionnel
J'utilise quasi jamais (et même moins...) les TCD, je sais pas...
Je peux chercher ce soir de chez moi,la je suis au travail et j'en ai quasi autant que dab.... donc pas trop le temps "à la minute".
Tu me dis si tu veux que je regarde en soirée (pas de pb le cas échéant)
 

Abby003

XLDnaute Nouveau
Merci déjà pour ton aide.

Ha oui si tu peux m'aider sur le TCD c'est avec plaisir, car je suis dans la panade.
 

micheldu52

XLDnaute Occasionnel
Bonsoir,
Je pense qu'ici
tu as la piste pour ta question en mettant ta formule * la colonne où figurent les 1 ou 0 si filtré. Le multiplié par zéro va neutraliser la ligne.
Dis moi....
Cordialement
Michel
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas