XL 2016 Somme.si.ens avec comme un critère une liste de roulante avec choix multiples

Merlin258413

XLDnaute Occasionnel
Bonjour à tous,
Je me permet de solliciter votre aide et je vous en remercie par avance.
J'ai un tableau synthèse et je dois faire une somme.si.ens.
Le premier critère correspond à mon Id Agence celui-ci ne pose pas de problème.

La ou cela se corse c'est pour le critère 2
Je désire faire une selection multiple sur ma cellule A1 utilisée comme critère 2.
Par exemple Janvier + Février ou Janvier + mars ou Janvier + Février + Mars
4- Plage-critères 2 = Onglet BASE Colonne A "Période"
3- critère 1 = Onglet SYNTHESE Cellule A1

Dans mon exemple ci joint j'ai indiqué la formule avec une sélection simple



Encore merci pour votre aide
 

Pièces jointes

  • Somme.xlsx
    13 KB · Affichages: 25

chris

XLDnaute Barbatruc
Bonjour

Pourquoi compliquer : les listes à sélection multiples nécessitent du VBA dont la sélection n'est pas aisément récupérable par formule

Un petit TCD avec un ou deux segments...

Edit : Salut djidji59430, plus rapide ;)
 

Pièces jointes

  • SommeTCD.xlsx
    20.6 KB · Affichages: 19

JHA

XLDnaute Barbatruc
Bonjour à tous,

Non, il y a deux critères dans le somme.si.ens()
Code:
=SOMME.SI.ENS(BASE!C:C;BASE!B:B;A7;BASE!A:A;$A$1)
Il y a aussi sommeprod()
Code:
=SOMMEPROD((BASE!$B:$B=$A7)*(BASE!$A:$A=$A$1);BASE!$C:$C)

mais le TCD est le plus simple

JHA
 

djidji59430

XLDnaute Barbatruc
=SOMME.SI.ENS(BASE!$C$2:$C$119;BASE!$A$2:$A$119;SYNTHESE!$A$1;BASE!$B$2:$B$119;SYNTHESE!$A7)
BASE!$A$2:$A$119;SYNTHESE!$A$1; Par rapport a la cellule a1 (janvier 18) qui n'est meme pas une "vraie" date. Donc on ne peut pas s'en servir pour delimiter une période, par exemple.
BASE!$B$2:$B$119;SYNTHESE!$A7 Par rapport a l'ID agence
soit 2 critéres

maintenant, si tu veux plus de critéres, il faut les definir et leur atrtibuer une cellule !
 

Discussions similaires

Haut Bas