Somme d'heures négatives et positives

SETILA

XLDnaute Nouveau
Bonjour,

Sur une feuille Excel je souhaiterais avoir le total de plusieurs cases comprenant des heures positives et négatives. Afin de pouvoir afficher les heures négatives, j'ai du utiliser une formule transformant les résultats en texte et en affichant la valeur absolue : =IF(C3<C2;"-"&TEXT(ABS(C3-C2);"[h]:mm:ss");C3-C2)

Il me faut maintenant le total de toutes ces cases. J'ai trouvé une formule avec des SOMMEPROD mais qui ne semble pas fonctionner.
Je vous joint un document Excel avec ce que je souhaite faire.

En vous remerciant par avance,
Setila
 

Fichiers joints

Victor21

XLDnaute Barbatruc
Supporter XLD
Bonsoir, SETILA.

Selon le même principe (pas forcément le plus simple) :
VB:
=SI(SOMME(A3;D3;G3;J3;M3;P3;S3)-SOMME(A2;D2;G2;J2;M2;P2;S2)<0;"-"&TEXTE(ABS(SOMME(A3;D3;G3;J3;M3;P3;S3)-SOMME(A2;D2;G2;J2;M2;P2;S2));"[h]:mm:ss");SOMME(A3;D3;G3;J3;M3;P3;S3)-SOMME(A2;D2;G2;J2;M2;P2;S2))
 

SETILA

XLDnaute Nouveau
Bonsoir, SETILA.

Selon le même principe (pas forcément le plus simple) :
VB:
=SI(SOMME(A3;D3;G3;J3;M3;P3;S3)-SOMME(A2;D2;G2;J2;M2;P2;S2)<0;"-"&TEXTE(ABS(SOMME(A3;D3;G3;J3;M3;P3;S3)-SOMME(A2;D2;G2;J2;M2;P2;S2));"[h]:mm:ss");SOMME(A3;D3;G3;J3;M3;P3;S3)-SOMME(A2;D2;G2;J2;M2;P2;S2))

Hello Patrick,

Merci pour ton aide mais ça ne fonctionne pas?!

Setila
 

Jocelyn

XLDnaute Barbatruc
Bonjour le Forum,
Bonjour Setila,

Un essai en fichier par formule matricielle

Cordialement

Oup's Bonjour Victor 21 :)

EDIT : Modification du fichier suite a l'oubli d'une colonne (merci a Victor21 de me l'avoir signalé ;))
 

Fichiers joints

Dernière édition:

Discussions similaires


Haut Bas