Somme décaler matricielle

CAMPEN

XLDnaute Junior
Bonjour à tous,
Je souhaite faire une somme décaler prenant en compte 1 condition.
J'ai fait une somme.si.ens() en intégrant un décaler, le tout me renvoyant un message d'erreur.
Je pense donc qu'il faut intégrer une formule matricielle mais ne maîtrise pas la logique.
En PJ l'exemple avec les formules en colonnes C3:C6

Merci d'avance de votre aide
 

Fichiers joints

Roblochon

XLDnaute Occasionnel
Bonjour,

Une simple SOMME.SI.ENS ne suffit pas ? : =SOMME.SI.ENS($G$2:$G$21;$F$2:$F$21;$B3;$E$2:$E$21;$C$1) en c3 à tirer vers le bas
Ou un TCD comme dans le fichier joint.

Bon après-midi
 

Fichiers joints

CAMPEN

XLDnaute Junior
Merci de la réponse. Je crois que je n'ai pas été suffisamment précis car je souhaite obtenir un résultat cumulé.
Si par exemple en C1 je mets 02, je souhaite obtenir la somme de 01+02.

Cdt
 

Roblochon

XLDnaute Occasionnel
Re,

Oui, je viens juste de m'en apercevoir et corrigé ici dans le fichier joint.

"Mettre les '01' ... '05' sous forme de nombre et avec un format personnalisé: "00" (ou pas)

Bonne soirée
 

Fichiers joints

Jocelyn

XLDnaute Barbatruc
Bonjour le forum,
Bonjour CAMPEN, Roblochon,

A tester en C3 et a étirer vers le bas

VB:
=SOMMEPROD(($E$2:$E$21*1<=$C$1*1)*($F$2:$F$21=B3)*$G$2:$G$21)
Cordialement
 

CAMPEN

XLDnaute Junior
Merci à vous deux pour votre aide. Les 2 formules répondent au besoin, je n'ai plus que le choix !

Cdt
 

Discussions similaires


Haut Bas