Somme de valeurs selon variable

WoodyW

XLDnaute Nouveau
Salut,

voilà, je suppose que ça va être assez simple mais j'y arrive pas:

je voudrais faire la somme de certaines valeurs de la colonne C en fonction de la variable correspondante dans la colonne E (0,1,NA), donc additionner toutes les cellules de C qui ont une variable à 1.

De même, je voudrais trouver le maximum de la colonne C parmis les cellules ayant une variable dans E de 0.

Merci d'avance :)
 

Tibo

XLDnaute Barbatruc
Re : Somme de valeurs selon variable

Bonjour,

Peut-êtr avec SOMME.SI :

Code:
=SOMME.SI($E:$E;1;$C:$C)

Pour la 2ème, une formule matricielle :

Code:
=MAX(SI(E1:E100=0;C1:C100))
Formule matricielle à valider par CTRL + MAJ + ENTREE

Pour les formules matricielles, on ne peut se référer à la colonne entière. Il faut donc définir une plage de cellules.

Essaye et dis nous

@+
 
Dernière édition:

bcharef

XLDnaute Accro
Re : Somme de valeurs selon variable

Bonjour WoodyW,
Bonjour à toutes et à tous.

Si, j'ai bien compris:

Pour additionner toutes les cellules de C qui ont une variable à 1

=SOMME.SI(E:E;1;C:C)

Pour trouver le maximum de la colonne C parmis les cellules ayant une variable dans E de 0

=MAX(SI(E:E=0;C:C)) Formule Matricielle à valider par CTRL +MAJ +ENTREE

A vous lire et bon courage

BCharef

Edit : Salut Tibo
 
Dernière édition:

WoodyW

XLDnaute Nouveau
Re : Somme de valeurs selon variable

Parfait les deux marchent, merci :) !

J'en ai une autre un peu plus compliquée:

Pour tout mon tableau:
si dans E la variable vaut "", somme de (C*D-C) correspondants.

Je vois pas comment présenter ça par rapport à la matrice?

Merci d'avance ^^
 

bcharef

XLDnaute Accro
Re : Somme de valeurs selon variable

Re bonjour WoodyW & Tibo,
Re bonjour à toutes et à tous.

Un essai avec une formule matricielle.

Code:
=SOMME(SI(E:E="";(C:C)*(D:D)-(C:C)))
A vous lire et bon courage.

Cordialement.

BCharef
 
Dernière édition:

WoodyW

XLDnaute Nouveau
Re : Somme de valeurs selon variable

Non celle là marche pas, ça m'affiche 0 à tous les coups :/
 

Tibo

XLDnaute Barbatruc
Re : Somme de valeurs selon variable

re,

Peux-tu joindre un extrait de ton fichier (anonymisé) pour qu'on comprenne mieux ce qui se passe.

A te (re)lire

@+
 

bcharef

XLDnaute Accro
Re : Somme de valeurs selon variable

Re bonjour WoodyW & Tibo,
Re bonjour à toutes et à tous.

Essaye de nous joindre un fichier enregistré sous Excel 2003.

Cordialement.

BCharef
 

Tibo

XLDnaute Barbatruc
Re : Somme de valeurs selon variable

re,

Comme indiqué précédemment, il s'agit d'une formule matricielle.

Ce qui implique de la valider par CTRL + MAJ + ENTREE

Réessaye, ça marche.

@+
 

bcharef

XLDnaute Accro
Re : Somme de valeurs selon variable

Re bonjour WoodyW & Tibo,
Re bonjour à toutes et à tous.

Un essai avec une formule matricielle


Code:
=SOMME(SI(E1:E4="";(C1:C4)*(D1:D4)-(C1:C4)))
A valider par CTRL + MAJ + ENTREE

Votre fichier est de retour.

Cordialement.

BCharef
 

Fichiers joints

WoodyW

XLDnaute Nouveau
Re : Somme de valeurs selon variable

Ah pardon oui çà marche, j'avais pas fait attention au Ctrl+maj+entrée.

Merci beaucoup,

à bientôt :)
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas