somme de valeurs selon des critères de choix

MAC

XLDnaute Nouveau
bonjour
je souhaite sommer des valeurs selon plusieurs critères de sélection

pouvez vous m'aider svp???

merci d'avance
 

Fichiers joints

BOISGONTIER

XLDnaute Barbatruc
Re : somme de valeurs selon des critères de choix

Bonjour,

=SOMMEPROD((A3:A9=I2)*(B3:B9=J2)*(C3:C9=K2)*D3:D9)

si le mois est aussi un critère:

=SOMMEPROD((A3:A9=I2)*(B3:B9=J2)*(C3:C9=K2)*DECALER($D$3:$D$9;;EQUIV(L1;D2:G2;0)-1))

JB
 
Dernière édition:

wilfried_42

XLDnaute Barbatruc
Re : somme de valeurs selon des critères de choix

Bonjour

voila ta formule, mais fait attention, dans ta colonne tu as études et dans ton critère il te manque un S
Code:
=SOMMEPROD(($A$3:$A$9=I2) * ($B$3:$B$9=J2)*($C$3:$C$9=K2)*(D$3:D$9))
 

pierrejean

XLDnaute Barbatruc
Re : somme de valeurs selon des critères de choix

bonjour MAC

Une solution Vba (macro evenementielle sur cellules I2 J2 K2 et macro somme en module1)
Note: En J2 j'ai orthographié études comme en colonne B

Edit : Salut Wil :)
 

Fichiers joints

MAC

XLDnaute Nouveau
Re : somme de valeurs selon des critères de choix

bonjour,

merci pour vos réponses ; la fonction sommeprod marche très bien si la zone de critère ne contient pas de cellule vide mais je souhaiterais avoir la possibilité de laisser un cellule si je veux faire une somme moins détaillée (seulement sur 1 ou 2 critères) mais en laissant la zone tel quel si je veux faire des simulations en direct.

ci joint le fichier
merci encore d'avance

bonne soirée
 

Fichiers joints

MAC

XLDnaute Nouveau
Re : somme de valeurs selon des critères de choix

merci beaucoup à tous et surtout à Monique ; c'est exactement çà que je voulais faire!!!

MERCI
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas