XL 2010 Somme de valeurs regroupées dans une liste

Chubby

XLDnaute Impliqué
Bonjour,

Mon titre doit en effrayer plus d'un... courage ne fuyez pas.
Voilà mon problème que j'ai retranscris simplement sous forme de couleur alors que ce sont des codes. Je dispose d'une liste de couleurs affectées d'une valeur que j'aimerais sommer selon l'appartenance à un groupe ou à un autre. Les couleurs sont dans une liste nommée.
Regardez le doc joint ça devrait vous aider à comprendre.
La fonction somme.si.ens devait à mon sens faire l'affaire mais que nenni.
Auriez vous une petite idée pour me faire décoller. Après je devrais pouvoir avancer sur un problème ressemblant ... je pense.

Merci de votre aide
 

Fichiers joints

CISCO

XLDnaute Barbatruc
Bonsoir

Tu peux faire avec
Code:
=SOMMEPROD(SI(ESTNUM(EQUIV(B12:B20;Liste_CouleursP;0));C12:C20)*1)
en matriciel, donc à valider avec les 3 touches Ctrl+maj+entrer.

@ plus

P.S : Ou avec SOMME(.... à la place de SOMMEPROD
 

Chubby

XLDnaute Impliqué
Bonjour Cisco, bonjour les zotres,
Merci pour ta formule. Je vais l'étendre à mon problème.
J'étais assez loin du compte apparemment. Mis à part que sans la matricielle ça ne marche pas mais qu'est ce qui justifie son emploi?
Je te remercie Cisco
Bonne journée à toi et à tous
 

CISCO

XLDnaute Barbatruc
Bonsoir

Bonjour Cisco, bonjour les zotres,
Merci...
Mis à part que sans la matricielle ça ne marche pas mais qu'est ce qui justifie son emploi?
...
Bonne journée à toi et à tous
Sans validation matricielle, avec EQUIV(B12:B20;Liste_CouleursP;0), Excel ne fera que la recherche correspondant à EQUIV(B12;Liste_CouleursP;0).

@ plus
 
Dernière édition:

R@chid

XLDnaute Barbatruc
Bonjour à tous,
Salut CISCO,
sans validation matricielle :
VB:
=SOMMEPROD(NB.SI(Liste_CouleursP;B12:B20)*(C12:C20))
Cordialement
 

Chubby

XLDnaute Impliqué
Bonjour R@chid, Cisco et les zotres,

Pas mal Rachid. Simple et efficace. Je vais maintenant passer à la phase 2 de mon problème et je ne serais pas surpris de faire appel à vos lumières.
En attendant, merci encore à vous deux pour ces solutions.
Bonne journée
 

Discussions similaires


Haut Bas