XL 2010 Somme de différentes valeurs selon leurs critères respectif.

sablondjoseph

XLDnaute Nouveau
Bonjour a tous.tes,
Comme le titre l'indique, j'ai un fichier excel de deux feuilles/pages(une ou les conditions doivent appliquer, l'autre les conditions), je veux obtenir le score de chaque ligne dans la colonne total(page 2), selon leurs critères respectif. J'ai essayé de sélectionner chaque case dans la somme.si mais il m'indique #valeur. Je ne sais pas quoi faire. JE pense que le fait que la plage soit discontinue pose problème. Je vous joint un fichier d'exemple.

Quelqu'un a une solution?
Cordialement.
 

Pièces jointes

  • Exemple.xls
    28 KB · Affichages: 6

sylvanu

XLDnaute Barbatruc
Supporter XLD
Bonjour sablondjoseph, jocelyn,
Un essai en PJ avec simplement la somme des critères :
VB:
=SI(D5="Male";0;Critère!$D$7)+SI(I5<10;0;Critère!$D$5)+SI(J5<1;0;Critère!$D$8)+SI(K5<1;0;Critère!$D$9)+SI(H5<I5/2;0;Critère!$D$10)+LIGNE()/10000
Le "LIGNE()/10000" sert juste au classement en colonne M avec :
Code:
=RANG(L5;$L$5:$L$100)
 

Pièces jointes

  • Exemple.xls
    23 KB · Affichages: 5

sablondjoseph

XLDnaute Nouveau
Bonjour sablondjoseph, jocelyn,
Un essai en PJ avec simplement la somme des critères :
VB:
=SI(D5="Male";0;Critère!$D$7)+SI(I5<10;0;Critère!$D$5)+SI(J5<1;0;Critère!$D$8)+SI(K5<1;0;Critère!$D$9)+SI(H5<I5/2;0;Critère!$D$10)+LIGNE()/10000
Le "LIGNE()/10000" sert juste au classement en colonne M avec :
Code:
=RANG(L5;$L$5:$L$100)
Merci a vous Sylvanu, c'est génial. Mais une toute petite explication du formule seras apprécié.
Dans la formule je ne trouve pas le critère pour: Mineur chef de ménage,
Je comprends pas non plus cette partie ( SI(H5<I5/2;0;Critère!$D$10) ), pourquoi le / en dessous de I5??
La ligne()/10000 ne marche pas, car ils ne sont pas en ordre, 1ér: 3; 2èm: 1 et 3èm: 2.
Pour finir a quoi sert le 0, c'est une négation non!! (si a<b n'est pas vérifié, faire cela )????
Cordialement.
 
Dernière édition:

sablondjoseph

XLDnaute Nouveau
re,
Bonjour sylvanu,

correction de ma formule pour tenir compte du sexe du chef de famille

cordialement
Merci aussi a vous, Jocelyn.
=SOMMEPROD((J6:L6>0)*(Critère!$C$5:$C$10=Tableau!$J$4:$L$4)*Critère!$D$5:$D$10)+((D6="female")*10)
Sincèrement, je rien compris dans cette formule marginale(a mes yeux, étant novice).
Des explications seras très apprécié.
Cordialement.
 

sylvanu

XLDnaute Barbatruc
Supporter XLD
Re,
Dans la formule je ne trouve pas le critère pour: Mineur chef de ménage,
Parce que dans votre fichier aucune cellule ne se rapporte à ce paramètre.
SI(H5<I5/2;0;Critère!$D$10)
Parce que le paramètre est "Ménages composé par la majorité de personne agées" donc j'ai fait Nombre total de personnes divisée par 2; Ce qui fait la majorité.
La ligne()/10000 ne marche pas
Si elle donne la partie décimale. ( mettez en format standard, vous verrez que 22 est en fait 22.0006.
car ils ne sont pas en ordre
Si, l'ordre est donné en colonne M.
Pour finir a quoi sert le 0, c'est une négation non
Si( condition;si faux,si vrai ) en fait quand c'est faux je met 0, sinon par défaut XL met FAUX.
 

sablondjoseph

XLDnaute Nouveau
Salut!
Merci pour votre réponse rapide.
Parce que dans votre fichier aucune cellule ne se rapporte à ce paramètre. => Mineur chef de ménage
Je pense en faisant une logique sur ces 2 paramètres: "Nombre des adultes entre 18 et 49 ans" et "Nombre de personne avec 50 ans ou plus" dans le sens ou leurs valeurs = 0. Et "Nombre de garçons entre 5 et 18 ans" > 1.
Le paramètre "Mineur chef de ménage" entre en jeux. Que pensez-vous???
Parce que le paramètre est "Ménages composé par la majorité de personne agées" donc j'ai fait Nombre total de personnes divisée par 2; Ce qui fait la majorité.
J'arrive toujours pas a comprendre la logique.
Si( condition;si faux,si vrai ) en fait quand c'est faux je met 0, sinon par défaut XL met FAUX.
Est-il possible de mettre plusieurs conditions dans un Si Ex: si (a>b et/ou c<>d faire ci ou çà) ?
 
Dernière édition:

JBARBE

XLDnaute Barbatruc
Bonjour sablondjoseph
C'est très simple comme je l'ai démontré !
Total score :
cellule M5 :
=SI(ET(Critère!D5=4;Critère!D6=15;Critère!D9=7;Critère!D10=6);Tableau!L5;"")
si dans la feuille Critère les cellules D5 =4 etc.... ) fermer la parenthèse !
On revient dans le tableau et on choisi la cellule L5 :
=E5+F5+H5+I5+K5 qui est une somme de cellules !
;"") veut dire sinon rien !
Pour les cellules suivantes c'est la même chose !
Bonne soirée !
 

sablondjoseph

XLDnaute Nouveau
Bonjour sablondjoseph
C'est très simple comme je l'ai démontré !
Total score :
cellule M5 :
=SI(ET(Critère!D5=4;Critère!D6=15;Critère!D9=7;Critère!D10=6);Tableau!L5;"")
si dans la feuille Critère les cellules D5 =4 etc.... ) fermer la parenthèse !
On revient dans le tableau et on choisi la cellule L5 :
=E5+F5+H5+I5+K5 qui est une somme de cellules !
;"") veut dire sinon rien !
Pour les cellules suivantes c'est la même chose !
Bonne soirée !
Oke merci, mais............. c'est dure tout ça, la logique reste très flou même plus dure que Java et Python(selon moi).
Merci encore a vous tous.tes.
 

Statistiques des forums

Discussions
286 624
Messages
1 877 552
Membres
160 769
dernier inscrit
Yudlo
Haut Bas