Résolu Somme conditionnelle sur nom et date

bambi

XLDnaute Occasionnel
Bonjour à tous

Mon problème est totalement basique, j'en ai conscience mais je tourne en bourrique
entre SOMMEPROD et SOMME.SI.ENS :confused:

Je voudrais tout simplement faire une somme basée sur deux critères : le nom et le mois de l'année
Exemple: somme des tomates en décembre 2016

Les données sont dans le tableau A
Et le résultat que je cherche à obtenir dans le tableau B

Merci de votre aide :)
 
Ce fil a été résolu! Aller à la solution…

Fichiers joints

thebenoit59

XLDnaute Accro
Bonjour Bambi.

Tu auras sans aucun doute des réponses plus belles et simples que la mienne, mais la voici :

VB:
=SOMMEPROD((MOIS($B$3:$B$27)=MOIS(F$2))*(ANNEE($B$3:$B$27)=ANNEE(F$2))*($A$3:$A$27=$E3)*($C$3:$C$27))
 
Ce message a été identifié comme étant une solution!

bambi

XLDnaute Occasionnel
Je pensais t'avoir remercié Benoist mais je ne vois pas mon message :oops:
Alors dans le doute, j'en poste un autre
Merci pour cette solution qui me convient parfaitement ;)
 

Dugenou

XLDnaute Barbatruc
Supporter XLD
Bonjour,
en F3, se recopie vers le bas et à droite :
Code:
=SOMME.SI.ENS($C$3:$C$27;$A$3:$A$27;$E3;$B$3:$B$27;">="&F$2;$B$3:$B$27;"<="&DATE(ANNEE(F$2);MOIS(F$2)+1;1))
Salut Benoit
 
Ce message a été identifié comme étant une solution!

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas