XL 2013 Somme conditionnelle matricielle

Peglar

XLDnaute Nouveau
Bonjour à tout le monde !
Je cherche à faire une somme conditionelle avec certainement les fonctions somme.si.en, index, equiv, sans passer par des maccros.
N'étant pas très à l'aise avec ces formules, je n'y arrive pas.

Vous trouverez dans le fichier ci-joint le fichier exemple.
Je cherche à sommer les montants de 'A', en fonction du mois, et dont les données sont contenus dans le tableau 'données d'entrées'.

J’espère avoir été clair.

Merci.
 

Pièces jointes

  • somme.xls
    29 KB · Affichages: 8

JHA

XLDnaute Barbatruc
Bonjour à tous,

Peut-être avec sommeprod

VB:
=SOMMEPROD(($O$5:$O$12=$B5)*(MOIS($N$5:$N$12)=MOIS(C$4))*(ANNEE($N$5:$N$12)=ANNEE(C$4))*($P$5:$P$12))
copier vers la droite et le bas

Edit: Bonjour Jocelyn ;)
JHA
 

Pièces jointes

  • somme.xls
    29.5 KB · Affichages: 2

Discussions similaires

Haut Bas