XL 2013 Somme conditionnelle matricielle

Peglar

XLDnaute Nouveau
Bonjour à tout le monde !
Je cherche à faire une somme conditionelle avec certainement les fonctions somme.si.en, index, equiv, sans passer par des maccros.
N'étant pas très à l'aise avec ces formules, je n'y arrive pas.

Vous trouverez dans le fichier ci-joint le fichier exemple.
Je cherche à sommer les montants de 'A', en fonction du mois, et dont les données sont contenus dans le tableau 'données d'entrées'.

J’espère avoir été clair.

Merci.
 

Fichiers joints

Jocelyn

XLDnaute Barbatruc
Bonjour le Forum,
Bonjour Peglar,

un essai en fichier joint

Cordialement

EDIT : Bonjour JHA :), même idée ;)
 

Fichiers joints

JHA

XLDnaute Barbatruc
Bonjour à tous,

Peut-être avec sommeprod

VB:
=SOMMEPROD(($O$5:$O$12=$B5)*(MOIS($N$5:$N$12)=MOIS(C$4))*(ANNEE($N$5:$N$12)=ANNEE(C$4))*($P$5:$P$12))
copier vers la droite et le bas

Edit: Bonjour Jocelyn ;)
JHA
 

Fichiers joints

JHA

XLDnaute Barbatruc
Bonjour à tous,

Tu peux aussi utiliser fin.mois()
VB:
=SOMMEPROD(($O$5:$O$12=$B5)*($N$5:$N$12>=C$4)*($N$5:$N$12<=FIN.MOIS(C$4;0))*($P$5:$P$12))
copier vers la droite et le bas

JHA
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas