Somme conditionnelle critère cellule contient date (N'importe !)

Yashine_78

XLDnaute Nouveau
Bonjour à tous

Je souhaiterai sommer dans un tableau tous les montants de la colonne B dont l'équivalent en colonne D est une date non un texte ou autres.

J'espère que ma question est assez claire.

Vous remerciant d'avance

Amicales salutations
 

Victor21

XLDnaute Barbatruc
Supporter XLD
Bonjour.

=SOMMEPROD(ESTNUM(D1: Dx)*B1:Bx)
additionnera toutes les valeurs entre B1 et Bx en face desquelles, en colonne D, figurera un nombre (quel que soit son format, date ou autre).
 

Yashine_78

XLDnaute Nouveau
Bonjour Victor

Je vous remercie pour votre retour, néanmoins, il faudrait que la formule me fasse la somme des valeurs contenues dans les cellules de la colonne B, mais uniquement celles dont les cellules de la colonne D contiennent des dates.

Le tableau est repris dans l'image ci-dessous :
La formule recherchée est censée faire sortir le total des factures réglées, qu'on distingue au fait qu'elles ont une date de règlement.

upload_2019-1-7_15-20-28.png


Cordialement
 

Fichiers joints

Victor21

XLDnaute Barbatruc
Supporter XLD
Re,

Merci pour vos remerciements, mais que pensez-vous que fait la formule que j'ai soumise à votre attention, pour peu que vous adaptiez les numéros de ligne à ceux du tableau que vous n'avez pas jugé utile de joindre ?

Remarque 1 : une date, c'est un nombre.
Remarque 2 : Une image, c'est joli, mais nous préférons un vrai fichier Excel (simplifié de préférence) sur lequel nous pouvons, si besoin, tester nos éventuelles propositions.
 

Yashine_78

XLDnaute Nouveau
Bonjour

Encore désolé pour la bourde,

J'ai joint le fichier, et j'avoue que j'ai bien tenté d'adapter votre formule.

Cordiales salutations
 

Fichiers joints

Victor21

XLDnaute Barbatruc
Supporter XLD
Re,

Peut-être parce que les dates en colonne D n'en sont pas (c'est du texte) ?
Ne proviendraient-elles pas d'un copier-coller ou d'une importation ?
 

Yashine_78

XLDnaute Nouveau
Bonsoir

En vérité ce sont des dates récupérées par formule, et celles qui sont dans le classeur que j'ai joint sont saisies en tant que dates.

Le souci est que je n'arrive pas à trouver l'expression pour déterminer la condition Format Date pour la somme.

Si vous avez compris mon souci, vous pourriez toujours me joindre un classeur EXCEL avec un tableau ayant la formule qui répond à mon besoin, ça serait très aimable de votre part.

Encore merci

Mes salutations du soir
 

Yashine_78

XLDnaute Nouveau
Re.

Je viens de modifier mon tableau en ajoutant des jours aux dates de la colonne C, et mes dates de la colonne D qui n'en étaient pas !!!!!! le sont devenus !!!!!!

La formule =SOMMEPROD(ESTNUM(D2:D6)*B2:B6) fonctionne à merveille !

Encore merci et surtout désolé pour la prise de tête que je vous ai causée !!!

Bonne soirée
 

Victor21

XLDnaute Barbatruc
Supporter XLD
Bonsoir, Yashine_78.

Je vous remercie pour votre retour, et vous félicite pour votre maîtrise du français, suffisamment inhabituelle pour être saluée - hormis peut-être un "e" manquant à "devenues".

Bonne soirée également, Yashine_78 :)
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas