SIGNE ASTRO SELON UNE DATE DE NAISSANCE

Moi69

XLDnaute Occasionnel
Bonjour le Forum,

Je viens vers vous car j'ai un petit souci avec une formule de recherche. Je souhaite connaître le signe astrologique (en O20) d'une personne selon sa date de naissance (en O19) quelque soit celle-ci.
J'ai une colonne où j'ai mis les différents signes selon le jour (col A et F) mais si je mets une formule du type =RECHERCHEV(O19;$A$20:$F$385;6;0) le résultat est #N/A. Chose qui est logique vu que dans la col A la date est pour l'année en cours.
Connaissez-vous une formule qui prendrai en compte juste le jour et le mois quel que soit l'année.
J'espère avoir été assez clair. Je vous remercie d'avance.
 

Fichiers joints

Staple1600

XLDnaute Barbatruc
Bonjour

Bonjour le Forum,
Connaissez-vous une formule qui prendrai en compte juste le jour et le mois quel que soit l'année.
J'espère avoir été assez clair. Je vous remercie d'avance.
Issu des archives du forum
Une jolie formule d'Alain Vallon
https://www.excel-downloads.com/threads/signe-du-zodiaque.59330/post-306866
(à utiliser avec la police adéquate pour faire joli ;))
 
Dernière édition:

Chris401

XLDnaute Accro
Bonjour
Essaye :
Code:
=SI(O19="";"";CHOISIR(EQUIV(DATE(;MOIS(O19);JOUR(O19));{0;21;51;81;112;142;174;206;237;268;298;328;356});"Capricorne";"Verseau";"Poisson";"Bélier";"Taureau";"Gémeaux";"Cancer";"Lion";"Vierge";"Balance";"Scorpion";"Sagittaire"))
 

Staple1600

XLDnaute Barbatruc
Bonjour Chris401

C'est quasi la même formule, non ?
Salut,

En A1 la date de naissance
Cellule au format police = Windings
=INDEX({'g';'h';'i';'^';'_';'z';'a';'b';'c';'d';'e';'f';'g'};EQUIV(DATE(;MOIS(A1);JOUR(A1));{0;21;51;81;112;142;174;206;237;268;298;328;356};1))

Pour avoir les noms du signe du zodiaque et non les symboles :
=INDEX({'Capricorne';'Verseau';'Poissons';'Bélier';'Taureau';'Gémeaux';'Cancer';'Lion';'Vierge';'Balance';'Scorpion';'Sagittaire'};EQUIV(DATE(;MOIS(A1);JOUR(A1));{0;21;51;81;112;142;174;206;237;268;298;328;356};1))

AV [aaa]
Sauf que celle-ci dormait dans la poussière du fil que je cite dans mon premier message ;) et que la tienne est dépoussiérée (plus de problème de ' et de ")
 

Moi69

XLDnaute Occasionnel
Bonjour



Issu des archives du forum
Une jolie formule d'Alain Vallon
https://www.excel-downloads.com/threads/signe-du-zodiaque.59330/post-306866
(à utiliser avec la police adéquate pour faire joli ;))
Merci c'est tout à fait ça que je cherchais. j'avais mal cherché dans le forum car je ne l'avais pas vu !!
 

Moi69

XLDnaute Occasionnel
Bonjour
Essaye :
Code:
=SI(O19="";"";CHOISIR(EQUIV(DATE(;MOIS(O19);JOUR(O19));{0;21;51;81;112;142;174;206;237;268;298;328;356});"Capricorne";"Verseau";"Poisson";"Bélier";"Taureau";"Gémeaux";"Cancer";"Lion";"Vierge";"Balance";"Scorpion";"Sagittaire"))
Celle-ci est parfaite. Merci
 

Discussions similaires


Haut Bas