Office 365 Si une cellule excel est vide, comment renvoyer à une suivante et ainsi de suite

Maureen

XLDnaute Nouveau
Bonjour à tous,
n'étant pas une experte sur Excel, j'ai besoin de votre aide, je cherche un moyen simple pour avoir un listing à jour de la flotte de véhicule.
Je m'explique, j'ai un tableau comportant en zone A1 le nom du conducteur et en zone B1 l'immatriculation, en C1 la nouvelle immatriculation, en D1 la nouvelle immatriculation, chaque nouvelle immatriculation correspondant à un changement de véhicule dans l'année .
je cherche une formule qui indique que si D1 est vide, les données de C1 seront exploités, mais si C1 est vide, je souhaite avoir l'info de la zone B1. Une sorte de retour en arrière.
Cela me permettrait en temps réel d'ajouter mes nouveaux mouvements de plaque, et de sortir un listing à jour via se renvoi d'information.

voici globalement :

tableau de base
A1...……………….... B1.........................C1.......................D1
Dupont..........xx-123-xx.............yy-456-yy............zz-789-zz
Moreau.........aa-000-aa.............bb-111-bb
Bernard……….az-999-za

tableau recap souhaité:
Dupont..........zz-789-zz
Moreau.........bb-111-bb
Bernard.........az-999-za

quelle formule puis-je utiliser pour obtenir ce tableau recap ?
merci à vous
Maureen
 

Fichiers joints

Ikito

XLDnaute Occasionnel
Bonjour,

Une proposition avec le fichier joint.

Le problème ici, c'est que les infos du véhicule pour le conducteur xxxx doivent être sur la même ligne que les infos récapitulatives.
 

Fichiers joints

Maureen

XLDnaute Nouveau
Bonjour Pierre Jean,

c'est tout à fait ce qu'il me faut, j'ai essayé de comprendre la manipulation pour la démultiplier aux autres colonnes mais rien n'a y faire. car il se peut que j'ai besoin à l'avenir de l'étendre à de nouvelle colonne pour plus d'information. est ce possible de m'indiquer la manipulation.
encore une chose est-il possible que ce recap soit sur un autre onglet de façon isoler. car mon fichier de base est assez long.

merci encore
 

Ikito

XLDnaute Occasionnel
Le plus simple est de fournir un fichier avec un jeu de tests au plus proche de la mise en forme du fichier de destination, ainsi, toutes les relations sont déjà créées et n'ont pas à être modifiées :)
 

patricktoulon

XLDnaute Barbatruc
bonjour
si je me fie a ton fichier voici un exemple de tableau 2 colonnes avec nom et next imat avec une simple formule etendue
la formule
=SI($A2<>"";INDEX(B2:AA2;1;NB.SI(B2:AA2;"*"));"")
demo
demo3.gif


tout simplement ;)
pas de macro
 

Fichiers joints

patricktoulon

XLDnaute Barbatruc
et tu pourrais te simplifier la tache en mettant une colonne attribuée au next imat en tre le nom et la premiere dans ton tableau original
tu aurais ainsi ton tableau recap next imat en prenant que les deux premières colonnes ;)
voir capture
Capture.JPG
en B2
=SI($A2<>"";INDEX(C2:AB2;1;NB.SI(C2:AB2;"*"));"")
et étendre la formule sur tout le tableau
 

JHA

XLDnaute Barbatruc
Bonjour à tous,

Formule matricielle à essayer en "B3"
VB:
=DECALER(INDIRECT(ADRESSE(EQUIV($A3;Conducteur;0);8));;MAX(SI(($H$2:$ZZ$2=B$2)*(INDIRECT("$H"&EQUIV($A3;Conducteur;0)&":$zz"&EQUIV($A3;Conducteur;0))<>"");COLONNE($H$2:$ZZ$2)-8)))
Copier vers la droite et le bas

JHA
 

Fichiers joints

patricktoulon

XLDnaute Barbatruc
re
et si je me fie encore a l'exemple de pierre jean

MAIS!!! que j'organise les données de façon a ce que la next imat soit toujours la dernière donnée d'un changement en gris dans la capture
voir capture ci dessous
on a des formules relativement simples même pour un débutant avec un peu d’expérience avec les formules index equiv
Capture.JPG
je joint le fichier

c'est relativement propre ;) et sans macro
bien entendu toujours étendre les formule vers le bas
peut être englober aussi dans un si pour ne pas avoir les N/A
;)
 

Fichiers joints

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas