XL 2013 Séparation adresse sur plusieurs colonnes (avec Bis et autres difficultés) [RESOLU]

elisium

XLDnaute Nouveau
Bonjour,

J'ai une liste de plus de 3000 adresses et pour créer des exportations automatique j'ai besoin de séparer
les Numéros dans 1 colonne et la suite de l'adresse dans une deuxième colonne.
mais j'ai bien évidement des numéros de rue en 1-Bis ou 1-Ter ou même en Quater et Quinquies.
et également des noms de rue qui contiennent des chiffres comme rue du 18 .......,
et aussi des adresses sans numéro, (ou le tout doit aller en deuxième colonne donc)

j'ai tenter pleins formules et bout de codes trouvés ça et là mais ça plante sur pas mal de lignes.

Si le fait d'accoler les Bis, Ter, et autres au N° peut faciliter les choses, cela ne me dérange pas
(ex 1BIS au lieu de 1-BIS actuellement)


je joins un fichier qui contient la colonne adresses pour infos.
Merci pour toute l'aide ou les infos.
Cdt.

JL
 

Fichiers joints

Dernière édition:

JBOBO

XLDnaute Accro
Re : Séparation adresse sur plusieurs colonnes (avec Bis et autres difficultés)

Bonjour,

Pour les numéros :
Code:
=SI(ESTNUM(CNUM(GAUCHE(A3;1)))=FAUX;"";STXT(A3;1;(SI(ESTNUM(CNUM(GAUCHE(A3;1)))=FAUX;"";CHERCHE(" ";A3;1)))-1))
Pour l'adresse :
Code:
=SI(ESTNUM(CNUM(GAUCHE(A3;1)))=FAUX;A3;STXT(A3;NBCAR(SI(ESTNUM(CNUM(GAUCHE(A3;1)))=FAUX;"";STXT(A3;1;(SI(ESTNUM(CNUM(GAUCHE(A3;1)))=FAUX;"";CHERCHE(" ";A3;1)))-1)))+1;999))
 

R@chid

XLDnaute Barbatruc
Re : Séparation adresse sur plusieurs colonnes (avec Bis et autres difficultés)

Bonjour @ tous,
en C3 :
Code:
=SI(ESTNUM(GAUCHE(A3)*1);GAUCHE(A3;TROUVE(" ";A3)-1);"")
en D3 :
Code:
=SUPPRESPACE(SUBSTITUE(A3;C3;))
@ tirer vers le bas



@ + +
 
Dernière édition:

elisium

XLDnaute Nouveau
Re : Séparation adresse sur plusieurs colonnes (avec Bis et autres difficultés)

Bonjour, je viens de tester vos formules elles fonctionnent super.
Encore merci à vous deux pour cette aide.

Bonne journée.

Cdt.

JL
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas