Sauter une ligne en fonction d'un critère

Gengiskhan

XLDnaute Junior
Bonjour le Forum,

mon problème est le suivant,
à partir d'une liste, en l'occurence dans mon exemple une liste de Mois avec des sous-totaux, j'aimerais à l'aide d'une formule pouvoir isoler ces dernier afin de n'afficher que la liste de mois.
je précise que mon exemple à l'aide de Mois, faisant apparaître des sous totaux par trimestre soit toutes les 3 lignes ne peut pas être un support à la fomule.

je joins un exemple concrès avec une tentavive hasardeuse inefficace.


merci d'avance
 

Fichiers joints

Dernière édition:

ERIC S

XLDnaute Barbatruc
Re : Sauter une ligne en fonction d'un critère

Bonsoir

a essayer

=SI(GAUCHE(INDIRECT("$A" & D1+1);5)="total";D1+2;D1+1)

en D2 et tirer vers le bas
 

Gengiskhan

XLDnaute Junior
Re : Sauter une ligne en fonction d'un critère

Merci bcp ERIC S pour ta réponse, je rencontre un problème similaire aujourd'hui, cette même formule doit également me permettre de gérer les doublons.
ci-joint la variante de l'exemple précédent.

merci bcp
 

Fichiers joints

ERIC S

XLDnaute Barbatruc
Re : Sauter une ligne en fonction d'un critère

Bonjour

si tu n'as qu'un seul doublon possible

=SI(GAUCHE(INDIRECT("$A" & D1+1);5)="total";SI(GAUCHE(INDIRECT("$A" & D1+2);5)="total";D1+3;D1+2);D1+1)

devrait marcher
 

Gengiskhan

XLDnaute Junior
Re : Sauter une ligne en fonction d'un critère

Bonjour, et encore merci pour cette rapidité, mais tu soulèves justement la bonne condition, en effet il peut y avoir plusieurs doublons consécutifs.

je me demandais si il n'y aurait-il pas un moyen de s'en sortir avec la fonction decaler ?
 

ERIC S

XLDnaute Barbatruc
Re : Sauter une ligne en fonction d'un critère

Bonjour

ce n'est pas réellement une question de doublons mais de lignes consécutives avec "total"

j'ai effacé tes tableaux résultats et utilisé les colonnes D, E, et F

en D je regarde les successions de "total", en fait si la cellule commence par total, au cas ou tu aurais des choses type "total trimestre" ou "total année"

D1 : =SI(GAUCHE($A1;5)="total";D2+1;0) et je tire



en E1 : 1
en E2 : =SI(GAUCHE(INDIRECT("$A" & E1+1);5)="total";INDIRECT("$D" & E1+1)+E1+1;E1+1) et je tire

c'est donc une solution à 2 colonnes intermédiaires

en F, plutôt que recherche, tu peux utiliser index :
en F2: =INDEX($A:$A;E2) et tu tires
 
Dernière édition:

Gengiskhan

XLDnaute Junior
Re : Sauter une ligne en fonction d'un critère

C'est parfait, merci beaucoup Eric.
 
Dernière édition:

Discussions similaires


Haut Bas