saisie automatique d'une cellule à partir d'une autre

light

XLDnaute Nouveau
bonjour, j'ai réalisé un tableau comportant 8 colonnes avec une colonne intitulée "DESIGNATIONS" et une autre intitule "code désignations" mais j'ai abrégé en "CD" ce que je voudrais c'est pouvoir rien qu'en esquissant un code dans "CD" avoir la désignation correspondante dans "DESIGNATIONS" mais je n'arrive pas à trouver la fonction qui pourrait le faire j'en appelle alors à votre aide voient les tableaux en pièces jointes.
vous remerciant d'avance du temps que vous accorderiez à résoudre mon problème, merci.
 

Fichiers joints

mephis

XLDnaute Occasionnel
Re : saisie automatique d'une cellule à partir d'une autre

bonjour, il y a une solution mais elle est un peu longue

dim i as integer

for i =1 to 20

if cells(i,1)= "AG" then cells(i,2)="Agregats" 'SI DANS LA CELLULE A1 IL Y A AG ALORS ÉCRIRE AGREGATS DANS LA CELLULE B1
if cells(i,1)= "Bo" then cells(i,2)="Bois de Chantier"
...

Next

Et tu fais la même chose pour tous
 

piga25

XLDnaute Barbatruc
Re : saisie automatique d'une cellule à partir d'une autre

Bonjour,

Un essai à mettre en D4 puis à recopier vers le bas :

Ici avec vos deux fichiers
=SIERREUR(INDEX('[données de saisie.xlsx]Feuil1'!$F$2:$F$29;EQUIV(C4;'[données de saisie.xlsx]Feuil1'!$E$2:$E$29;0));"")
la en ajoutant une feuille que vous nommerez "Data" sur votre fichier "saisie mensuelle 2012"
=SIERREUR(INDEX(Data!F2:F29;EQUIV(C4;Data!E2:E29;0));"")
ou en nommant également vos données
=SIERREUR(INDEX(Désignation;EQUIV(C21;CodeD;0));"")
 

light

XLDnaute Nouveau
Re : saisie automatique d'une cellule à partir d'une autre

merci de repondre à ma question mephis mais j'essaye avec la fonction (si) et ça ne fonctionne pas et j'ai aussi essayé d'autres fonctions comme la (rechercheV Ou H) mais ça marche tjr pas
 

light

XLDnaute Nouveau
Re : saisie automatique d'une cellule à partir d'une autre

merci piga25 mais j'arrive pas à copier ta fonction dans mon tbl je crois que le mieux serait que tu la mette dans le tableau excel que j'ai mis en lien puis tu me le remet en lien ^^...voila qui m'aidera
 

piga25

XLDnaute Barbatruc
Re : saisie automatique d'une cellule à partir d'une autre

Bonjour,

Je pense connaître la raison de cela, vous avez des cellules fussionnées. Si cela n'est pas nécéssaire, autant ne garder une colonne.
Je vous ai mis les formules pour désignation et pour les chantiers.
Dans la feuille "juillet" : la formule qui va chercher les données sur l'autre fichier.
Dans la feuille "Aout" : la formule qui va chercher les données sur la feuille "Data"
Dans la feuuille "Septembre" : la formule qui va chercher les données nommées sur la feuilles Data.
Dans la feuille "Octobre" : Idem septembre mais sans cellules fusionnées.
 

Fichiers joints

light

XLDnaute Nouveau
Re : saisie automatique d'une cellule à partir d'une autre

ça marche parfaitement maintenant vs aviez raison pour les cellules fusionnées mission rendement menée piga25
encore merci...on a pas fini de collaborer ;)
 

Discussions similaires


Haut Bas