1. Ce site utilise des "témoins de connexion" (cookies) conformes aux textes de l'Union Européenne. Continuer à naviguer sur nos pages vaut acceptation de notre règlement en la matière. En savoir plus.

XL 2010 Série de numérotation Alpha numerique

Discussion dans 'Forum Excel' démarrée par Sackmoh, 11 Janvier 2017.

  1. Sackmoh

    Sackmoh XLDnaute Nouveau

    Inscrit depuis le :
    11 Janvier 2017
    Messages :
    3
    "J'aime" reçus :
    0
    Sexe :
    Masculin
    Bonjour,

    Je souhaiterais avoir une formule pour la numérotation Alphanumérique (ACH16120001) d'une série d’écritures comptables.
    L'objectif est d'avoir le même N° de pièce pour chaque Référence. A noter que le nombre de ligne pour chaque référence varie et l'ordre n'est pas important.

    Ci-dessous le tableau

    upload_2017-1-11_10-46-40.png
     
  2. Papou-net

    Papou-net XLDnaute Barbatruc

    Inscrit depuis le :
    8 Mai 2007
    Messages :
    4698
    "J'aime" reçus :
    275
    Utilise:
    Excel 2010 (PC)
    Bonjour Sackmoh, et bienvenue,

    Ci-joint un classeur exemple avec formatage personnalisé de la colonne a.

    Il suffit d'entrer le n° d'ordre (1, 2, 3, ...) et de valider par Entrée.

    Bonne journée.

    Cordialement.
     

    Pièces jointes:

    Sackmoh aime votre message.
  3. Sackmoh

    Sackmoh XLDnaute Nouveau

    Inscrit depuis le :
    11 Janvier 2017
    Messages :
    3
    "J'aime" reçus :
    0
    Sexe :
    Masculin
    Merci beaucoup QUOTE pour l'accueil, c'est vrai que c'est rapide avec ton ton fichier et il vas falloir que je fasse tout manuellement surtout si j'ai 1 millier de numérotation a faire. Ya t'il pas d'autre méthode plus efficiente?
     
  4. Dranreb

    Dranreb XLDnaute Barbatruc

    Inscrit depuis le :
    31 Janvier 2011
    Messages :
    11377
    "J'aime" reçus :
    626
    Sexe :
    Masculin
    Habite à:
    Belfort
    Utilise:
    Excel 2016 (PC)
    Bonjour.
    Si en D c'est une date de l'année passée avec format personnalisé jj/mm,
    En B3 :
    Code (Text):
    =TEXTE($D3;"""ACH""aamm""000""jj")
     
    Sackmoh aime votre message.
  5. Sackmoh

    Sackmoh XLDnaute Nouveau

    Inscrit depuis le :
    11 Janvier 2017
    Messages :
    3
    "J'aime" reçus :
    0
    Sexe :
    Masculin

    Merci Dranreb, en D (Référence) c'est: Ex 01/12 = 1ere facture de Decembre ; 02/12 = 2e facture de décembre ainsi de suite.
     
  6. Dranreb

    Dranreb XLDnaute Barbatruc

    Inscrit depuis le :
    31 Janvier 2011
    Messages :
    11377
    "J'aime" reçus :
    626
    Sexe :
    Masculin
    Habite à:
    Belfort
    Utilise:
    Excel 2016 (PC)
    Alors si c'est du texte :
    En B3 :
    Code (Text):
    ="ACH16"&DROITE($D3;2)&"00"&GAUCHE($D3;2)
    ou bien
    Code (Text):
    =TEXTE(DROITE($D3;2)*100000+GAUCHE($D3;2);"""ACH16""0000000")
    Edit: Bonsoir Papou-net
     
    Dernière édition: 11 Janvier 2017
  7. Papou-net

    Papou-net XLDnaute Barbatruc

    Inscrit depuis le :
    8 Mai 2007
    Messages :
    4698
    "J'aime" reçus :
    275
    Utilise:
    Excel 2010 (PC)
    RE

    Autre solution dans exemple bis ci-joint.

    La colonne B contient le format personnalisé et les cellules B1:B30 la formule qui prend en compte la date en colonne A.

    Il est facile de recopier ces formules sur tes cellules concernées, voire sur l'ensemble de la colonne.

    Cordialement.

    PS: bonsoir Dranreb
     

    Pièces jointes:

Partager cette page