XL 2016 [Résolut] Copier une valeur d'une autre feuille à partir de données de lignes et colonnes

Nico.grondin

XLDnaute Nouveau
Bonjour à tous,

Comment trouver un titre de sujet qui convienne à ma problématique ?!? Il sera plus simple de vous l'expliquer !

Dans une première feuille, j'ai un récapitulatif de lieux, et noms de services et d'effectifs en fonction de ces deux critères. Dans ma 2ème feuille, je souhaite, si je choisi un lieux et un service, savoir quel est l'effectif disponible. Je n'ai pas trouvé de réponse approprié dans le forum pour le moment.


Merci à tous !



Feuille 1 : Données

Colonne A : Colonne B : Colonne C : Colonne D :

Lieux Service 1 Service 2 Service 3

A Résultat 11 Résultat 12 Résultat 13
B Résultat 21 Résultat 22 Résultat 23
C Résultat 31 Résultat 32 Résultat 33
D Résultat 41 Résultat 42 Résultat 43
... ... ... ...



Feuille 2 : Résultats attendus

Colonne A : Colonne B : Colonne C :

Lieux Service Effectif

A 1 Résultat 11
A 2 Résultat 12
B 1 Résultat 21
D 3 Résultat 43
... ... ...
 

Nico.grondin

XLDnaute Nouveau
Bonjour,

Effectivement :) Le fichier ci-joint.

Mon souhait serait que dans les cases orange, je puisse retrouver le nombre correspondant de la feuille "Effectifs"


Merci !
 

Fichiers joints

Dugenou

XLDnaute Barbatruc
Supporter XLD
Bonjour,
En C4 : =INDEX(Effectifs!$D$5:$F$9;EQUIV(Tableau!A4;Lieux;0);EQUIV(Tableau!B4;Service;0))
se recopie vers le bas. Adapter D5:F9 à vos véritables données.
Cordialement

Edit : amélioration : s'adapte automatiquement en fonction des zones nommées Service et lieux :
=INDEX(DECALER(Effectifs!$D$5;;;NBVAL(Lieux);NBVAL(Service));EQUIV(Tableau!A4;Lieux;0);EQUIV(Tableau!B4;Service;0))
 
Dernière édition:

Nico.grondin

XLDnaute Nouveau
Super, c'est parfait !

Merci Dugenou pour cette réponse si rapide et simple de mise ne œuvre, je ne connaissais pas cette fonction EQUIV.
Mieux vaut 1 que sait que 10 qui cherchent !


Au plaisir de continuer à prendre vos solutions sur le forum :)

Cdt,

Nicolas
 

JBOBO

XLDnaute Accro
Bonjour à tous,

un poil plus court avec sommeprod.

En C4 : =SOMMEPROD((Lieux=Tableau!$A4)*(Service=Tableau!$B4)*(Effectifs!$D$5:$F$9))
 

Nico.grondin

XLDnaute Nouveau
Merci aussi JBOBO, très facile de la réutiliser dans des tableaux fixes

Je suis aller voir dans l'aide Excel pour la fonction SOMMEPROD, et je n'ai pas du tout d'explication pour une utilisation de ce genre.

Au top !

Nicolas
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas