XL 2016 [RESOLU] Utilisation de RECHERCHEV pour renseigner une feuille selon une autre feuille du classeur

heru13

XLDnaute Nouveau
Bonjour à tous,

J’ai un classeur Excel avec 2 feuilles. Je voudrais que la feuille 2 récapitule les données traitées dans la feuille 1.

J’ai employé la formule =RECHERCHEV(A2;'1'!$A$2:$B$100;2;0)
Cela fonctionne mais, comment faire pour ne pas faire apparaitre l’erreur #N/A (quand le matériel n’est pas encore traité donc pas encore renseigné dans la feuille 1) et les valeurs nul ?

Merci d’avance.
 

Fichiers joints

heru13

XLDnaute Nouveau
Merci Matt_b et chris,

Pour Matt_b, je ne dois pas mettre les valeurs manquantes car elles ne sont pas encore traitées. En fait j'ai 300 PC (UC...) qui doivent passer de windows 7 en Windows 10. je récupère par 10 les PC mais pas forcément dans l'ordre...

J'ai donc adapté ma formule comme ceci:
=SI(ESTNA(RECHERCHEV(A2;'1'!$A$2:$B$100;2;0));"";RECHERCHEV(A2;'1'!$A$2:$B$100;2;0))
Et j'ai modifié le format en nombre comme tu as fait pour ne plus avoir les zéros:
0;;;@

Pour chris, si je ne veut pas utiliser le format nombre, ta formule =SI(ERREUR(RECHERCHEV(A2;'1'!$A$2:$B$100;2;0);"") me remonte une erreur:

Je pense que c'est plutôt: =SIERREUR(RECHERCHEV(A2;'1'!$A$2:$B$100;2;0);"")
Et cela marche effectivement ! les zéros reste

Merci a vous deux.
 

Fichiers joints

Dernière édition:

Discussions similaires


Haut Bas