XL 2016 [Resolu]somme.si.ens+sous.total

Sarah2308

XLDnaute Nouveau
J'aimerais dans mes formules cachées actualiser un somme.si.ens en fonction des filtres effectués dans un tableau en dessous.
En gros j'aimerais faire un sous.total(9;..) de cette formule : =SOMME.SI.ENS($AD$36:$AD$132;$AG$36:$AG$132;">=0";$D$36:$D$132;$J$9) (Dans PJ, cellule en jaune (G17).
Par exemple si je fais un filtre dans le tableau de dessous et je ne choisis que l'asso X, j'aimerais que mon résultat en G17 prenne en compte mon filtre.
Et ainsi de suite pour toutes ces formules cachées qui me servent à ajuster mes totaux selon mes données (Ex : AE9)
 

Fichiers joints

Sarah2308

XLDnaute Nouveau
Désolée d'avoir heurté ta sensibilité Roblochon !
En effet, j'étais tellement en train de me triturer la tête que j'en ai oublié l'élémentaire.... Bonjour of course :) Et Merci d'avance à tous ! :)
 

Marjo2

XLDnaute Occasionnel
Bonjour,

Par simplicité, j'aurais mis en forme mes données (sans colonne ni ligne vide) et aurait crée un tableau croisée dynamique
 

Roblochon

XLDnaute Impliqué
bonjour,

voir si la solution du classeur joint produit les résultats voulus. En F17 le nom de l'association choisie, et en G17 la nouvelle formule.
Je n'ai pas vérifié manuellement le résultat.

Idée: mettre en F17 ou ailleurs une liste déroulante avec le nom des associations.

cordialement
 

Fichiers joints

Marjo2

XLDnaute Occasionnel
Alors pourquoi ne pas rajouter X en F17 et l'ajouter dans ta condition somme.si.ens
Ou même un menu déroulant
Si tu sélectionne rien, tu as le total sinon c'est en fonction de x, y etc

=SI(ESTVIDE(F17);SOMME.SI.ENS($Z$36:$Z$132;$AC$36:$AC$132;">=0";$D$36:$D$132;$F$9);SOMME.SI.ENS($Z$36:$Z$132;$AC$36:$AC$132;">=0";$D$36:$D$132;$F$9;$C$36:$C$132;F17))
 

Sarah2308

XLDnaute Nouveau
Franchement ! Merci à tous les deux ! J'ai enfin une solution qui tient la route !
Quand je pense à tout le temps passé pour trouver une solution.... Vous égayez ma fin de journée ! Merci encore !!! :D
 

Discussions similaires


Haut Bas