[RESOLU]Somme avec coefficient, cellules marquées et groupement de colonne

michelw

XLDnaute Nouveau
Bonjour,
Dans le fichier ci-joint je souhaiterai pour les colonnes D à M faire la somme des croix en multipliant par le coefficients situé sur la ligne 3. S'il n'y a pas de x il faudrait que cela compte comme zéro.
Pour les groupement de colonnes [N à P], [Q à S], [T à V], [W à Y] et [Z à AB] il faudrait vérifié que dans chaque groupement de colonnes figure au moins une croix avec l’intersection d'une ligne et si c’est le cas faire le même travail que précédemment c'est à dire faire la somme des croix en multipliant par le coefficients situé sur la ligne 3. S'il n'y a pas de croix dans ces groupements de colonne compter zéro par groupement. Enfin le nombre total de croix devrait figurer dans la colonne AC.
Pourriez-vous m'aider? En vous remerciant
 

Fichiers joints

Dernière édition:

JHA

XLDnaute Barbatruc
Re : Somme avec coefficient, cellules marquées et groupement de colonne

Bonjour à tous,

peut être
Code:
=SOMMEPROD((D9:AB9="x")*($D$3:$AB$3))
ou
Code:
=SOMMEPROD((D9:M9="x")*($D$3:$M$3))
Code:
=SOMMEPROD((N9:AB9="x")*($N$3:$AB$3))
JHA
 

michelw

XLDnaute Nouveau
Re : Somme avec coefficient, cellules marquées et groupement de colonne

Bonsoir,
Merci pour votre aide, j'étais effectivement troublé par les groupements de colonnes vides.
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas