[Résolu] Résultat formule toujours égal à 0

Al dabaran

XLDnaute Nouveau
Salut le forum !!

J'ai une question au sujet d'un document que je suis entrain de mettre à jour ; Ce que je ne comprends pas, c'est que je n'ai pas eu ce problème un an plus tôt...

Mon problème est donc le suivant :

Lorsque je saisi une valeur dans certaines cellules, ces dernières sont bien retenues. Par contre, quand il s'agit de saisir n'importe quelle formule, même une formule simple de type =H14, et bien le résultat est toujours égal à zéro !

J'ai jeté un œil dans les mises en formes conditionnelles et le format des cellules mais je ne trouve aucune piste !! De quoi s'agit-il à votre avis ??

Merci d'avance !!
 
Dernière édition:

JazzOn

XLDnaute Nouveau
Re : Résultat formule toujours égal à 0

Hello,
j'ai déjà vu ça, et il y avait deux possibilités...
soit l'option de calcul automatique est désactivée, et tu fais F9 pour lancer le calcul
soit excel buggue et le simple fait de le fermer et de le rouvrir peut fonctionner... ahh c'est beau parfois...
a+
 

Al dabaran

XLDnaute Nouveau
Re : Résultat formule toujours égal à 0

Hello,
j'ai déjà vu ça, et il y avait deux possibilités...
soit l'option de calcul automatique est désactivée, et tu fais F9 pour lancer le calcul
soit excel buggue et le simple fait de le fermer et de le rouvrir peut fonctionner... ahh c'est beau parfois...
a+

Hello & thank you for this answer !!

Je crois qu'effectivement, il s'agit d'un bogue. J'avais enregistré le fichier modifié et je l'ai réouvert mais le problème persistait. J'ai donc repris le fichier original que j'ai modifié de nouveau et là... miracle, ça marche !

On ne va pas chercher à comprendre... :p

@+
 

Al dabaran

XLDnaute Nouveau
Re : Résultat formule toujours égal à 0

Bonjour,
Juste une petite piste supplémentaire:
Cela pourrait venir d'une référence circulaire insoluble mais non détectée car case Itération cochée dans options, calculs.

Bonsoir à vous, bonsoir le forum,

Je reviens sur ce sujet car mon problème n'est en fait pas résolu. La fois dernières, j'avais fermé le classeur et retenté une modification de ce dernier pour que cela fonctionne. Sauf que là, cela ne semble pas fonctionner...

J'ai effectivement, une référence circulaire mais qui est détectée et qui n'a pas d'incidence sur mes calculs. Le fait que tu mentionnes cette piste, Dranreb, me pousse à aller voir cette erreur et la corriger, je vous tiendrai au courant. La case itération n'est pas activée dans les options.

A plus tard et merci !!
 

Al dabaran

XLDnaute Nouveau
Re : Résultat formule toujours égal à 0

Bonsoir le forum, le topic,

Bonsoir à vous, bonsoir le forum,

Je reviens sur ce sujet car mon problème n'est en fait pas résolu. La fois dernières, j'avais fermé le classeur et retenté une modification de ce dernier pour que cela fonctionne. Sauf que là, cela ne semble pas fonctionner...

J'ai effectivement, une référence circulaire mais qui est détectée et qui n'a pas d'incidence sur mes calculs. Le fait que tu mentionnes cette piste, Dranreb, me pousse à aller voir cette erreur et la corriger, je vous tiendrai au courant. La case itération n'est pas activée dans les options.

A plus tard et merci !!

Message pour confirmer que les soupçons de Dranreb étaient fondés, c'était la référence circulaire qui avait une influence sur le reste du classeur, bien qu'elle n'avait aucune incidence sur le reste des cellules...

Merci encore, problème résolu.
 

shearer

XLDnaute Nouveau
Si vous faites la somme d'une colonne avec ∑, la cellule indiquera =SOMME(...).
Donc même chose pour une opération entre plusieurs cellules de votre tableau, vous devez écrire =SOMME.
Cela s'applique si votre résultat est toujours négatif.
 

Statistiques des forums

Discussions
294 211
Messages
1 936 901
Membres
188 103
dernier inscrit
srr77