1. Ce site utilise des "témoins de connexion" (cookies) conformes aux textes de l'Union Européenne. Continuer à naviguer sur nos pages vaut acceptation de notre règlement en la matière. En savoir plus.

[RESOLU] Renseigner un tableau automatiquement selon un autre tableau.

Discussion dans 'Forum Excel' démarrée par heru13, 9 Février 2019.

  1. heru13

    heru13 XLDnaute Nouveau

    Inscrit depuis le :
    9 Février 2019
    Messages :
    4
    "J'aime" reçus :
    0
    Sexe :
    Masculin
    Habite à:
    MARSEILLE
    Utilise:
    Excel 2016 (PC)
    Bonjour à tous,

    Voilà sur Excel, un petit problème que je n’arrive pas résoudre.

    Sur une même feuille j’ai 2 tableaux.
    Le 1er tableau renseigne pour chaque atelier (A1 ou A2), le groupe d’élève (1 ou 2) qui va devoir passer en test.
    Ce tableau est renseigné manuellement.
    Le 2ème tableau récapitule par groupe les ateliers à passer selon les heures de passage.
    J’aimerai automatiser ce 2ème tableau pour éviter les erreurs de saisie.

    En fichier joint, un exemple simple avec 2 groupes (1 et 2) et 2 ateliers (A1 et A2)

    Si possible par une formule mais si trop compliqué par VBA.
    Bien sur, le véritable tableau est plus volumineux, 20 groupes pour 10 ateliers et c’est sur la journée.

    Merci d’avance.
     

    Pièces jointes:

    Dernière édition: 9 Février 2019
  2. Chargement...

    Discussions similaires - [RESOLU] Renseigner tableau Forum Date
    [Résolu]_Renseigner une cellule par rapport à une plage d'âges? Forum Excel 5 Septembre 2011
    [Résolu] DATEDIF et cellules vides Forum Excel Mardi à 18:58
    XL 2010 Aucun enregistrement dans la feuille Liste référentiels. [RESOLU] Forum Excel Mardi à 18:45
    XL 2016 [Résolu] Calcul nb de jours calendaires en excluant des jours de fermeture Forum Excel Vendredi à 17:28
    XL 2013 [RESOLU] Recherche nème donnée Forum Excel 12 Février 2019

  3. job75

    job75 XLDnaute Barbatruc

    Inscrit depuis le :
    15 Mai 2008
    Messages :
    26301
    "J'aime" reçus :
    2311
    Sexe :
    Masculin
    Habite à:
    Paris
    Utilise:
    Excel 2013 (PC)
    Bonsoir heru13, bienvenue sur XLD,

    Formule en C8 à tirer à droite et vers le bas :
    Code (Text):
    =SIERREUR(INDEX($A:$A;EXP(LN(SOMMEPROD((C$3:C$4=$B8)*LIGNE(C$3:C$4)))));"")
    EXP(LN()) permet de neutraliser le cas où SOMMEPROD est nulle (groupe non trouvé).

    A+
     

    Pièces jointes:

  4. heru13

    heru13 XLDnaute Nouveau

    Inscrit depuis le :
    9 Février 2019
    Messages :
    4
    "J'aime" reçus :
    0
    Sexe :
    Masculin
    Habite à:
    MARSEILLE
    Utilise:
    Excel 2016 (PC)
    Salut à toi job75,

    Bravo, je viens d'adapter ta formule sur mon tableau final, cela fonctionne du feu de dieu.
    En fichier joint, mon tableau final.

    Je n'aurais pas crus qu'avec une formule si courte et sans besoin de VBA, on arrive à un tel résultat.

    Un grand merci pour ta réactivité et félicitation pour XLD, rarement vue un forum au si bien foutu.

    Bon dimanche et à bientôt ;)
     

    Pièces jointes:

  5. job75

    job75 XLDnaute Barbatruc

    Inscrit depuis le :
    15 Mai 2008
    Messages :
    26301
    "J'aime" reçus :
    2311
    Sexe :
    Masculin
    Habite à:
    Paris
    Utilise:
    Excel 2013 (PC)
    Re,

    Formule plus simple en C8 de ce fichier (2) :
    Code (Text):
    =SIERREUR(INDEX($A$3:$A$4;EQUIV($B8;C$3:C$4;0));"")
    Bonne nuit.
     

    Pièces jointes:

  6. heru13

    heru13 XLDnaute Nouveau

    Inscrit depuis le :
    9 Février 2019
    Messages :
    4
    "J'aime" reçus :
    0
    Sexe :
    Masculin
    Habite à:
    MARSEILLE
    Utilise:
    Excel 2016 (PC)
    Hello job75,

    Effectivement, en modifiant avec cette nouvelle formule, c'est plus clair et cela fonctionne !

    Merci, bonne semaine.
     

Partager cette page