[RESOLU] Renseigner un tableau automatiquement selon un autre tableau.

heru13

XLDnaute Nouveau
Bonjour à tous,

Voilà sur Excel, un petit problème que je n’arrive pas résoudre.

Sur une même feuille j’ai 2 tableaux.
Le 1er tableau renseigne pour chaque atelier (A1 ou A2), le groupe d’élève (1 ou 2) qui va devoir passer en test.
Ce tableau est renseigné manuellement.
Le 2ème tableau récapitule par groupe les ateliers à passer selon les heures de passage.
J’aimerai automatiser ce 2ème tableau pour éviter les erreurs de saisie.

En fichier joint, un exemple simple avec 2 groupes (1 et 2) et 2 ateliers (A1 et A2)

Si possible par une formule mais si trop compliqué par VBA.
Bien sur, le véritable tableau est plus volumineux, 20 groupes pour 10 ateliers et c’est sur la journée.

Merci d’avance.
 

Fichiers joints

Dernière édition:

job75

XLDnaute Barbatruc
Bonsoir heru13, bienvenue sur XLD,

Formule en C8 à tirer à droite et vers le bas :
Code:
=SIERREUR(INDEX($A:$A;EXP(LN(SOMMEPROD((C$3:C$4=$B8)*LIGNE(C$3:C$4)))));"")
EXP(LN()) permet de neutraliser le cas où SOMMEPROD est nulle (groupe non trouvé).

A+
 

Fichiers joints

heru13

XLDnaute Nouveau
Salut à toi job75,

Bravo, je viens d'adapter ta formule sur mon tableau final, cela fonctionne du feu de dieu.
En fichier joint, mon tableau final.

Je n'aurais pas crus qu'avec une formule si courte et sans besoin de VBA, on arrive à un tel résultat.

Un grand merci pour ta réactivité et félicitation pour XLD, rarement vue un forum au si bien foutu.

Bon dimanche et à bientôt ;)
 

Fichiers joints

job75

XLDnaute Barbatruc
Re,

Formule plus simple en C8 de ce fichier (2) :
Code:
=SIERREUR(INDEX($A$3:$A$4;EQUIV($B8;C$3:C$4;0));"")
Bonne nuit.
 

Fichiers joints

heru13

XLDnaute Nouveau
Hello job75,

Effectivement, en modifiant avec cette nouvelle formule, c'est plus clair et cela fonctionne !

Merci, bonne semaine.
 

Discussions similaires


Haut Bas