[Résolu]mise en forme conditionnelle

DragonBallZ1981

XLDnaute Nouveau
Bonjour tout le monde,

J'ai un souci avec les mise en forme conditionnelle

J'ai différent tableaux (tous identiques), ou dans deux cases j'ai ces formules

Tableau 1 : A858:J872
en B868 -> =SI(B863="";"";SI(B867="";"";B867-B863))
en B869 -> =(SI(OU(B863<>"";B867<>"");SOMME(F858:F872);""))


Tableau 2 : A877:J891
j'ai les mêmes formules en cases

en B887 -> =SI(B882="";"";SI(B886="";"";B886-B882))
en B888 -> =(SI(OU(B882<>"";B886<>"");SOMME(F877:F891);""))

lorsque ces deux cases ont un nombre identique elle doivent devenir verte sinon elles deviennent rouge

Pour le tableau 1 ca fonctionne alors que pour le tableau 2 ca reste rouge (alors que le nombre dans mes deux case est bien identique.

j'ai créer mes formules conditionnelle sans souci mais excel refuse de me les mettre en verte y aurai-t-il un truc a désactiver dans excel ou changer le format des case ou autre ??

Merci de vos réponse.

Pour info ces cases ont une formule récupérant des nombres dans d'autre case, et ce que je capte pas c'est que si je modifie les nombre (de facont a avoir deux chiffres identique certaine fois ca fonctionne)

Merci
 
Dernière édition:

jmps

XLDnaute Barbatruc
Re : mise en forme conditionnelle

Bonjour DragonBallZ,

Sans voir les mises en forme c'est difficile de répondre.
N'aurais-tu pas un problème d'arrondi ?
 

JHA

XLDnaute Barbatruc
Re : mise en forme conditionnelle

Bonjour à tous,

Es-tu sur que les résultats sont égaux à la décimale?
As-tu essayé avec la fonction ent() dans tes formules?

JHA
 

jmps

XLDnaute Barbatruc
Re : mise en forme conditionnelle

Bien vu JHA mais grillé à une fraction de seconde :p
 

DragonBallZ1981

XLDnaute Nouveau
Re : mise en forme conditionnelle

Merci de vos réponses, dans mes formules, je n'ai pas d'arrondi, et je peux pas me servir de la fonction ENT() car j'ai besoin des décimals.

je joint mon fichier si vous voulez voir

faisant plus d'1MO je l'ai upper ailleur ->ICI<-

mon problème se trouve dans la feuille "a remplir",
vous y verrez plein de tableau identique dont mon souci dans les tableaux (22, 23, 25, 32, 33, 34, 35, 39, 42, 43, 44, 47, 48 et 50). Le mot "erreur" est marqué alors qu'il n'y as pas d'erreur pour moi.

Merci de votre aide
 
Dernière édition:

JHA

XLDnaute Barbatruc
Re : mise en forme conditionnelle

Re,

Tu as bien un problème d'arrondi
en "B317" 3,42999999999999
en "B318" 3,43

Essaies en "B317"
=SI(B312="";"";SI(B316="";"";ARRONDI(B316-B312;2)))
JHA
 

jmps

XLDnaute Barbatruc
Re : mise en forme conditionnelle

Bon, grillé à mon tour JHA ;)
J'avais la même réponse.
 

DragonBallZ1981

XLDnaute Nouveau
Re : mise en forme conditionnelle

Merci infiniment effectivement ca fonctionne ainsi que pour tous les autres tableaux

Mais comment ca se fais que j'avais un souci d'arrondi alors que mes chiffres sont des chiffres direct et non récupérer d'une opération ??
 

jmps

XLDnaute Barbatruc
Re : mise en forme conditionnelle

Merci infiniment effectivement ca fonctionne ainsi que pour tous les autres tableaux

Mais comment ca se fais que j'avais un souci d'arrondi alors que mes chiffres sont des chiffres direct et non récupérer d'une opération ??
Non, tes résultats viennent de RECHERCHEV sur la feuille Copie ASS qui utilise des formules de multiplications associées à des divisions.
Ceci explique celà.
 

DragonBallZ1981

XLDnaute Nouveau
Re : mise en forme conditionnelle

Ha oui exact, j'avais pas pensé a la recherchev,

Problème résolu et encore merci a vous deux.

Bon week-end.
 

Discussions similaires


Haut Bas