XL 2016 [RESOLU] Copier contenu des cellules d’une feuille vers une autre selon critères.

heru13

XLDnaute Nouveau
Bonjour à tous.

Petit problème que je n'arrive pas à résoudre.
Voilà, dans un classeur Excel, j'ai une feuille avec une liste de nom-prenom-age-adresse
Et dans la 2ème feuille Excel, une liste plus nombreuse avec nom-prenom-age-adresse mais avec certains nom identiques (attention aux homonymes)

Je désirerais, copier l'adresse des personnes de la feuille 2 dans la colonne adresse de la feuille 1 pour les personnes identiques.

Un exemple restreint dans le fichier joint.

si quelqu'un a une idée..

A bientôt.
 

Fichiers joints

JHA

XLDnaute Barbatruc
Bonjour à tous,

A essayer cette formule matricielle:
VB:
=SIERREUR(INDEX('f1'!$D$2:$D$5;EQUIV($A2&$B2&$C2;'f1'!$A$2:$A$5&'f1'!$B$2:$B$5&'f1'!$C$2:$C$5;0));"Adresse inconnue")
Valider par Ctrl+Maj+Entrée
copier vers le bas

JHA
 

Fichiers joints

heru13

XLDnaute Nouveau
Et bien impec...

Je viens de transcrire ta formule sur mon projet que je je galérais à remplir... 4 tableaux de 500 lignes.pffff

Un grand merci à toi JHA et bravo pour ce site (une mine d'or)

Bon week-end !
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas