[Resolu] Compter occurrences sans reclasser

Shpountz

XLDnaute Occasionnel
Bonjour à tous

Je connais une formule pour compter les occurrences (ici des couleurs) mais comme j'ai besoin de les exporter plus loin je dois les reclasser par ordre numériques

Je voudrais savoir si il y a une possibilité de le faire sans reclassement ?

Un petit fichier est peut être plus explicatif...

Merci à vous pour votre aide

Amicalement
François
 

Fichiers joints

Shpountz

XLDnaute Occasionnel
Re-bonjour
En fait quand je l'adapte à mon tableau cela ne fonctionne pas...
J'ai bien recopié le code du module

Function ColorCountIf(ZoneDeRecherche As Object, Modele As Range) As Integer

Application.Volatile True
ColorCountIf = 0

MaCoul = Modele.Interior.ColorIndex
For Each cell In ZoneDeRecherche
If cell.Interior.ColorIndex = MaCoul Then ColorCountIf = ColorCountIf + 1
Next cell

End Function

Dans un module de mon classeur.
J'ai aussi changé les formules pour les adapter à mon classeur mais il me marque "absent"

Amicalement
Francois
 

Dugenou

XLDnaute Barbatruc
Supporter XLD
il faut revoir la formule qui utilise le colorcountif
le absent s'affiche en cas d'erreur : donc on ne trouve pas la ligne à compter avec le equiv.
=SIERREUR(ColorCountIf(DECALER($E$10:$AJ$10;EQUIV(B5;$A$11:$A$19;0););$A$6);"absent")
ah : un détail : faut activer les macros
 

Shpountz

XLDnaute Occasionnel
Bon....
C'est de ma faute cela fonctionne
Mais j'avais copié le module dans le mauvais classeur

Un grand merci pour l'aide
Amicalement
Francois
 

Shpountz

XLDnaute Occasionnel
Re
J'ai encore une petite question concernant la formule elle fonctionne très bien lorsque je sélectionne toute les cellules ($E$10:$AJ$10) mais je ne nesa is pas comment faire pour avoir un résultat que sur certaines cellules ?

En fait j'ai besoin de faire un calcul sur AA / R / P / Y / T / AB / I / AI / AJ / AE

Merci d'avance
Amicalement
François
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas