[Résolu]Compter nombre de cellule d'une colonne contenant une lettre...

GuillaumA

XLDnaute Occasionnel
Bonjour à tous,
Suite à quelques années sans pratiquer Excel, certaines bases m'échappent.
De mémoire, ce site rassemble une communauté d'experts et je viens quérir votre aide !

J'ai la table suivante:
A (Nom société ) B (Type A) C (Type B) D (Prospect ) E (Hot Lead) F (Sales)
ENGI de type A + Prospect
ABC de type B + Hot Lead
ABIO de type A + Sales
ACCENT de type A + Prospect

J'aimerai calculer le nombre de prospect pour une société de type A.

Pour le nombre de prospect total en colonne D, j'utilise =NB.SI(D$2: D$1000;"x")
Mais comment faire en sorte de ne compter que les prospects de type A ? J'avoue ne plus savoir comment faire...
Ci-joint un excel associé. https://we.tl/INww2HGMib

N.B: Un "x" est présent dans les deux cellules contenant les deux critères de différenciation d'un client.

Merci à vous de votre considération.
Cordialement,
Guillaume
 
Dernière édition:

GuillaumA

XLDnaute Occasionnel
Bonjour FaridP.
Le site Wetransfer semble avoir ponctuellement un soucis.
j'indiquerai lorsque ce dernier fonctionnera à nouveau.

++
 

Jocelyn

XLDnaute Barbatruc
Bonjour le Forum,
Bonjour GuillaumA, FarideP,

Comme FaridP je ne peux pas ouvrir le fichier mais a tester quand même une formule du genre

=SOMMEPROD((D$2: D$1000="x")*(B2:B1000="y"))

Cordialement

EDIT ah ah suivant ton fichier cela donnerait

=SOMMEPROD((B2:B5="X")*(D2: D5="x"))
 

GuillaumA

XLDnaute Occasionnel
Bonjour jocelyn.
C'est une excellente solution, fonctionnant à merveille.
Il est temps pour moi de retravailler le panel de formules disponibles; je ne me souvenais plus de SOMMEPROD...

Bonne fin de journée et encore merci pour ton aide.
++

Guillaume
 

FaridP

XLDnaute Occasionnel
Jocelyn a été trop rapide pour moi.

Content que tu aies pu solutionner ton problème.

Bonne fin de journée à tous,

Farid
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas