[résolu] comment compter le nbre de cellules différentes si ?

guylaincoud

XLDnaute Nouveau
bonjour,

Problème classique et facile je suppose mais que je ne parviens à résoudre si possible sans passer par du VBA (car je ne maitrise pas bien):

comment compter le nombre de cellules différentes dans une première colonne dont l'argument de la 2ème colonne est égale à une valeur donnée

ex: NOMBRE DE cellule différentes en 1ère colonne si A dans la 2ème colonne ? (réponse = 3) (pour k réponse 2 et s réponse 1)

1 A
1 A
1 K
1 K
2 K
2 A
2 A
3 A
3 S

modele excel en PJ
merci d'avance
 

Fichiers joints

Dernière édition:

JHA

XLDnaute Barbatruc
Re : comment compter le nbre de cellules différentes si ?

Bonjour à tous,

A essayer, formule matricielle.

=SOMME((FREQUENCE(SI($B$1:$B$38="A";EQUIV($A$1:$A$38;$A$1:$A$38;0));LIGNE($A$1:$A$38))>0)*1)

Edit: Bonjour Bebere, pas compris la même chose, c'est pourquoi j'ai utilisé la fonction Frequence

JHA
 

Fichiers joints

Dernière édition:

Discussions similaires


Haut Bas