XL 2010 [Résolu] cherche à extraire des données à partir de 2 petits tableaux présent sur la même feuille

fanadegra

XLDnaute Occasionnel
Bonsoir, je suis bloqué sur une formule, j'ai essayé avec somme prod et equiv mais cela passe pas.

Si vous avez une formule à me communiquer, je pourrai ainsi continuer mon fichier.

un petit fichier en pièce jointe.

http://www.cjoint.com/c/FIyxqlAuBJz

Merci d'avance pour votre aide.
 

R@chid

XLDnaute Barbatruc
Bonsoir,
tu aurais pu joindre le fichier directement sur le forum sans passer par un site intermédiaire.
en B21 :
Code:
=SOMMEPROD((A$3:F$15=A21)*(H$3:M$15))
@ tirer vers le bas


@ + +
 

fanadegra

XLDnaute Occasionnel
Bonjour R@achid, Bonjour à tous

Un grand merci pour cette formule, je n'avais pas vu la fonction "Téléverser un fichier"

Bon dimanche
 

fanadegra

XLDnaute Occasionnel
Bonjour à tous,

sur le fichier test la formule fonctionne parfaitement,
par contre sur le fichier d'origine beaucoup plus lourd j'ai une erreur #valeur
pourtant j'ai vérifié le format de chaque cellule concernée. j'ai utilisé la fonction majuscule () pour le texte
Une idée ?

Merci d'avance
 

R@chid

XLDnaute Barbatruc
Bonjour,
je ne vois pas pourquoi tu utilises MAJUSCULE() ?
#VALEUR vient peut être de tailles des plages qui ne sont pas identiques.

Sans fichier je ne peux pas apporter de l'aide.
 

R@chid

XLDnaute Barbatruc
Re,
il y a une valeur texte parmi les valeurs numériques cellule I6.
soit il faut la corriger.
ou bien utiliser la formule suivante, en B21 :
Code:
=SOMMEPROD(N(A$1:F$20=A21);H$1:M$20)
@ tirer vers le bas


@ + +
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas