[Résolu]Ajouter une condition à somme.si.ens

fr832

XLDnaute Occasionnel
Bonsoir à tous;
J'aliment un diagramme grâce à cette formule
=SOMME.SI.ENS(EEI!$M$11:$M$5756;EEI!$N$11:$N$5756;ValeurBarreDéfilement;EEI!$O$11:$O$5756;Année)
Le mois est sélectionné par ValeurBarre Défilement (1 à 12 qui correspond au mois calendaire)

Je voudrais rajouter à cette formule que si la ValeurBarreDéfilement est égal à 13 alors le résultat sera la cellule P38

Je n'arrive pas à combiner cette formule

Par avance merci de votre aide.

Amitiés
 
Dernière édition:

R@chid

XLDnaute Barbatruc
Re : Ajouter une condition à somme.si.ens

Bonsoir,
un fichier sera plus parlant, pourquoi exactement la cellule P38 ?
on peut toute fois limiter la ValeurBarreDéfilement à 12 comme valeur max.
sinon,
Code:
=SOMME.SI.ENS(EEI!$M$11:$M$5756;EEI!$N$11:$N$5756;MIN(12;ValeurBarreDéfilement);EEI!$O$11:$O$5756;Année)
ou ce que tu souhaites :
Code:
=SOMME.SI.ENS(EEI!$M$11:$M$5756;EEI!$N$11:$N$5756;SI(ValeurBarreDéfilement>12;P38;ValeurBarreDéfilement);EEI!$O$11:$O$5756;Année)
@ + +
 

fr832

XLDnaute Occasionnel
Re : Ajouter une condition à somme.si.ens

Bonsoir rachid
merci pour ton aide la cellule P38 correspond à la somme des valeurs de tous les mois, de cette façon j'alimente mon graphique soir par mois soit l'année.

merci
 

fr832

XLDnaute Occasionnel
Re : Ajouter une condition à somme.si.ens

Bonjour à tous je reviens vers vous car la formule de rachid ne fonctionne pas sur mon classeur.

ci dessus les deux formules qui fonctionnent indépendament mais que je n'arrive pas à regrouper en une seule formule

me renvoie FAUX si la valeur de ma barre de défilement est égale à 13 (suite à une évolution de mon classeur la cellule de ma somme annuel est P40 au lieu de P38
=SI(ValeurBarreDéfilement=13;$P$40)
Formule qui me calcule le nombre d'heures par mois sélectionné par la valeur de la barre de défilement

=SOMME.SI.ENS(EEI!$M$11:$M$5756;EEI!$N$11:$N$5756;ValeurBarreDéfilement;EEI!$O$11:$O$5756;Année)
Par avance un grand merci pôur votre aide

bon dimanche à tous
 

R@chid

XLDnaute Barbatruc
Re : Ajouter une condition à somme.si.ens

Bonjour,
merci de joindre un fichier exemple.

@ + +
 

fr832

XLDnaute Occasionnel
Re : Ajouter une condition à somme.si.ens

Bonjour rachid j'ai essayé de mettre une réduction de mon classeur pour l'exemple.

Merci de te pencher sur mon problème.

Amitiés
 

Fichiers joints

R@chid

XLDnaute Barbatruc
Re : Ajouter une condition à somme.si.ens

Re,
Code:
=SI(ValeurBarreDéfilement=13;P27;SOMME.SI.ENS(Antipol!$S$11:$S$5756;Antipol!$T$11:$T$5756;ValeurBarreDéfilement;Antipol!$U$11:$U$5756;Année))

@ + +
 

fr832

XLDnaute Occasionnel
Re : Ajouter une condition à somme.si.ens

Bonsoir, super et un grand merci pour ton aide bonne fin de week-end

Amitiés
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas