XL 2019 Reporter cellule en fonction de plusieurs critère

vba95

XLDnaute Nouveau
Bonjour,

Dans le fichier en pièce jointe je souhaite que dans mon onglet "Besoin DÉCOUPE" les valeurs en jaune soient reportées automatiquement en fonction des critères en rouge.

La contrainte est que les données dans l'onglet "Réservé OF" peuvent variées de 10 à 100000 lignes.

Merci de votre aide
 

Fichiers joints

GALOUGALOU

XLDnaute Impliqué
bonjour vba95
question
les valeurs en jaune doivent elle être reportées dans l'onglet reservé OF ?
les valeurs en jaune sont dans les colonnes cdef , mais les tableaux figurant dans les autres colonnes sont-ils concernés ?
cordialement
galougalou
 

herve62

XLDnaute Barbatruc
Oui , vrai en VBA mais une approche est bienvenue , car souvent le code rebute par manque de connaissance et la suite est parfois difficile
donc juste savoir si vba95 est capable de suivre même de base ?
 

job75

XLDnaute Barbatruc
Bonsoir à tous,

Le VBA ne simplifiera pas le problème, restons avec des formules.

Dans le fichier joint je me suis limité à remplir le tableau C13:F40 (2ème feuille) :

- entrer les formules en C13:F13, matricielles en C13 D13 E13 à valider par Ctrl+Maj+Entrée

- copier C13:F13 et Collage spécial-Formules sur C14:F40

- sélectionner C17:E20 et remplacer $13 par $17

- faire la même chose sur les plages de 4 lignes suivantes C21:E24 etc...

A+
 

Fichiers joints

job75

XLDnaute Barbatruc
Fichier (2) avec les 3 autres tableaux remplis :

- copier C13:F40 et coller sur H13:K40

- sur H13:K40 remplacer $C$5 par $H$5 et $D$5 par $I$5 (commande Remplacer)

- mêmes choses sur M13: P40 et R13:U40.
 

Fichiers joints

laurent3372

XLDnaute Impliqué
Supporter XLD
En C13, formule matricielle:
VB:
=SIERREUR(INDEX('Réservé OF'!$F:$F;PETITE.VALEUR(SI(($C$2<='Réservé OF'!$J$2:$J$12)*($L$2>='Réservé OF'!J2:J12)*(""&$A$13=""&'Réservé OF'!$B$2:$B$12)*(""&$C$5=""&'Réservé OF'!$C$2:$C$12)*($D$5='Réservé OF'!$D$2:$D$12);LIGNE('Réservé OF'!$D$2:$D$12));LIGNES(C$13:C13)));"")
Reporter la modif sur les autres cellules
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas