XL 2010 Repère date plus récente et Inscrire le texte d'une ligne

Marylgb

XLDnaute Nouveau
Bonjour,

Je souhaiterais que dans la colonne O repère la date la plus récente et inscrive le texte de la première ligne.
Exemple dans le fichier en PJ.
Merci d'avance,
bonne soirée
 

Pièces jointes

  • test .xlsx
    9.9 KB · Affichages: 4

Marylgb

XLDnaute Nouveau
bonjour

merci beaucoup, c'est parfait

une autre petite question ... ;-)
sauriez vous comment je peux modifier la formule ligne 3 pour avoir le rendu de la ligne 4 du fichier en PJ afin que cela compte également le nombre de jour quand il n'y pas pas de date de fin?

merci d'avance
bonne journée
 

Pièces jointes

  • TEST.xlsx
    11.7 KB · Affichages: 1

JHA

XLDnaute Barbatruc
Bonjour à tous,
Bonjour Rachid,

En "AO2"
VB:
=SIERREUR(EXP(LN(MIN(--(""&SI(ESTVIDE($F2);DATE(ANNEE($E2);12;31);$F2));FIN.MOIS(AO$1;0))-MAX((""&$E2)-1;FIN.MOIS(AO$1;-1))));"")
copier vers la droite et le bas.

JHA
 

Pièces jointes

  • TEST.xlsx
    11.8 KB · Affichages: 1

Marylgb

XLDnaute Nouveau
Bonjour à tous,
Bonjour Rachid,

En "AO2"
VB:
=SIERREUR(EXP(LN(MIN(--(""&SI(ESTVIDE($F2);DATE(ANNEE($E2);12;31);$F2));FIN.MOIS(AO$1;0))-MAX((""&$E2)-1;FIN.MOIS(AO$1;-1))));"")
copier vers la droite et le bas.

JHA
merci beaucoup

quand la date de début est sur l'année 2020 ou autre année est qu'il n'y a pas de date de fin la formule ne fonctionne pas.
existe t il une solution pour résoudre cela
merci d'avance
 

JHA

XLDnaute Barbatruc
Bonjour à tous,

J'ai pris l'année en "AO1" au lieu de "E2"
VB:
=SIERREUR(EXP(LN(MIN(--(""&SI(ESTVIDE($F2);DATE(ANNEE($AO$1);12;31);$F2));FIN.MOIS(AO$1;0))-MAX((""&$E2)-1;FIN.MOIS(AO$1;-1))));"")

JHA
 

Pièces jointes

  • TEST.xlsx
    11.8 KB · Affichages: 3

R@chid

XLDnaute Barbatruc
Bonjour @ tous,
Salut JHA,
une autre formule, en AO2 :
VB:
=SOMMEPROD(--(TEXTE(LIGNE(INDIRECT($E2&":"&SI($F2<>"";$F2;--"31/12/21")));"mm/aaaa")=TEXTE(AO$1;"mm/aaaa")))
@ tirer vers le bas et vers la droite


Cordialement
 

Discussions similaires

Haut Bas