Renvoyer les weekend au lundi d'après

jo1177

XLDnaute Junior
Bonjour le forum =)

J'ai un petit souci avec mon calendrier, je vais essayer de faire simple
Mon calendrier sert de renvoi à des formules d'un autre onglet.
Je voudrais dire à Excel que si la formule tombe sur un samedi ou un dimanche, alors celui-ci renvoi automaitiquement au lundi d'après.

J'ai déjà tenté d'utiliser la fonction "serie.jour.ouvrés" afin de créer un calendrier sans weekend, mais cela posait des problèmes de calcules car j'avais des semaines de 5 jours au lieu de 7, je suis donc à la recherche de nouvelles solutions... !

Pour résumer, je voudrais dire à Excel que samedi et dimanche=lundi, tout en gardant mon calendrier à 7 jours...

Avez vous une solution en tête à me proposer ?!
Merci d'avance =)

Jonathan
 

Modeste

XLDnaute Barbatruc
Re : Renvoyer les weekend au lundi d'après

Bonjour Jonathan,

Sans fichier, difficile de savoir comment les données sont présentées, s'il y a déjà des formules, où tu veux le résultat ... A toutes fins utiles, en considérant que ta date est en A3, tu peux tester:
Code:
=SI(JOURSEM(A3;2)=6;A3+2;SI(JOURSEM(A3;2)=7;A3+1;A3))

Edit: salut ROGER!
 

job75

XLDnaute Barbatruc
Re : Renvoyer les weekend au lundi d'après

Bonjour jo1177,

Si dans la formule de l'autre onglet vous utilisez par exemple Feuil1!A1 (la date en cellule A1 de Feuil1), remplacez cette référence par l'expression :

Code:
Feuil1!A1+(JOURSEM(Feuil1!A1)=1)+2*(JOURSEM(Feuil1!A1)=7)

Edit : salut à vous Roger et Modeste :)

A+
 
Dernière édition:

jo1177

XLDnaute Junior
Re : Renvoyer les weekend au lundi d'après

Bonjour à tous, et merci pour vos réponses =)

Cela fonctionne comme je le désirais, merci beaucoup !
Une dernière petite question, je viens de m'apercevoir que lorsque j'additionne un nombre quelquonque à une des dates, la formule ne fonctionne plus...

Par exemple, si je fais jeudi 4 février + 3 jours, alors Excel me donne comme résultat dimanche 7 février, alors que je désirerai qu'il me renvoi au lundi 8 février.

Ci-joint, un exemple sur feuille Excel pour plus de compréhension =)
En vous remerciant d'avance pour votre aide,

Jonathan
 

Pièces jointes

  • Exemple1.xls
    24.5 KB · Affichages: 74
  • Exemple1.xls
    24.5 KB · Affichages: 72
  • Exemple1.xls
    24.5 KB · Affichages: 70

jo1177

XLDnaute Junior
Re : Renvoyer les weekend au lundi d'après

Bonjour jeanpierre,
Merci pour votre réponse, mais je n'ai pas compris votre formule, car c'est exactement la même...
Pourriez vous m'expliquez ? Ou dois-je mettre dans la formule le "+3" ?
Merci =)

Jonathan
 

jeanpierre

Nous a quitté
Repose en paix
Re : Renvoyer les weekend au lundi d'après

Re,

Comprends pas ta question....

Pas besoin de mettre le +3, c'est lui qui était responsable de l'erreur.

La formule précédente est bonne telle qu'elle est donnée. J'ai simplement retiré le +3

Comme je ne sais pas expliquer autrement, vois ton fichier en retour.
 

Pièces jointes

  • Exemple1(1).zip
    7.8 KB · Affichages: 26
  • Exemple1(1).zip
    7.8 KB · Affichages: 30
  • Exemple1(1).zip
    7.8 KB · Affichages: 26

jo1177

XLDnaute Junior
Re : Renvoyer les weekend au lundi d'après

Re, et merci pour vos réponses
Autant pour moi, je me suis mal exprimé !

En fait, j'ai rajouter le "+3" car je dois aléatoirement additionner un nombre de jours à la formule "=SI(JOURSEM(A3;2)=6;A3+2;SI(JOURSEM(A3;2)=7;A3+1;A3))".
Par exemple, sur mon fichier ci joint, en A3 j'ai la date du "jeudi 4 février" et je veux rajouter 3 jours à cette date, ce qui nous donne logiquement en B3 la date du "dimanche 7 février".
Or je souhaiterais que si le résultat de l'addition tombe un samedi ou un dimanche, alors il me renvoi automatiquement au lundi suivant. Je voudrais donc que le résultat en B3 soit "lundi 8 février" et non pas "dimanche 7 février"... C'est pour cela que j'ai rajouté le "+3" dans la formule, et qui apparament pose problème...

Je voulais donc savoir a quel endroit de la formule dois-je rajouter mon "+3" ?
Merci beaucoup pour votre aide !

Jonathan
 

job75

XLDnaute Barbatruc
Re : Renvoyer les weekend au lundi d'après

Re, salut jeanpierre,

Il me semble qu'on a oublié mon post #4, non ??

Ici on reste dans le même onglet... Donc en B3 :

Code:
=A3+3+(JOURSEM(A3+3)=1)+2*(JOURSEM(A3+3)=7)

A+
 

Pièces jointes

  • Exemple(1).xls
    30.5 KB · Affichages: 33
  • Exemple(1).xls
    30.5 KB · Affichages: 40
  • Exemple(1).xls
    30.5 KB · Affichages: 40

job75

XLDnaute Barbatruc
Re : Renvoyer les weekend au lundi d'après

Re,

Formule qu'on peut d'ailleurs simplifier en effet :

Code:
=A3+3+(JOURSEM(A3)=5)+2*(JOURSEM(A3)=4)

A+
 

Pièces jointes

  • Exemple(2).xls
    30.5 KB · Affichages: 65
  • Exemple(2).xls
    30.5 KB · Affichages: 60
  • Exemple(2).xls
    30.5 KB · Affichages: 66
Haut Bas