Microsoft 365 renvoyer le titre de colonne après Grande valeur

soulaima

XLDnaute Nouveau
Bonjour à tous,
Je cherche une formule qui me permet de retourner l'en-tete de la colonne de la cellule de la plus grande valeur sachant que j'ai 2 feuilles excel s'il vous plait.
La formule de la plus grande valeur que j'utilise est: =GRANDE.VALEUR(SI((data!A1:A997=IMPRIMER!M3);data!F1:AL997;" ");1)
les en-tetes des colonnes se trouvent dans la feuille data (data!F1:AL1) et je dois retourner la valeur dans une autre feuille (imprimer).
j'ai essayé avec index et equiv mais ça n'a pas fonctionné.
Je vous remercie pour votre aide
Sans titre.png
Sans titre1.png
 

Roblochon

XLDnaute Barbatruc
Bonjour,

Vous auriez pu rompre les liens et mettre une date de critère qui soit présente dans la colonne A de data!
Pourquoi n'utilisez-vous pas les tableaux structurés ?

Dans le fichier joint, deux formule

En E14 :
=SIERREUR(AGREGAT(14;6;(data!$F$1:$AL$9)/(data!$A$1:$A$9=Feuil2!$M$3);1);0)
Qui donne la plus grande valeur de la ligne trouvée. Agregat n'a pas besoin d'être validée par CTRL+MAJ+ENTREE
En E13 pour le nom de colonne
=SIERREUR(INDEX(data!$A$1:$AL$1;1;AGREGAT(15;6;COLONNE(data!$F$1:$AL$9)/(data!$F$1:$AL$9=E$14)/(data!$A$1:$A$9=Feuil2!$M$3);1));"???")

Cordialement
 

Pièces jointes

  • Colonne GV.xlsx
    21 KB · Affichages: 3

soulaima

XLDnaute Nouveau
Bonjour,

Vous auriez pu rompre les liens et mettre une date de critère qui soit présente dans la colonne A de data!
Pourquoi n'utilisez-vous pas les tableaux structurés ?

Dans le fichier joint, deux formule

En E14 :

Qui donne la plus grande valeur de la ligne trouvée. Agregat n'a pas besoin d'être validée par CTRL+MAJ+ENTREE
En E13 pour le nom de colonne


Cordialem
 

Discussions similaires

Haut Bas