XL 2016 Remplir textbox avec RechercheV Equiv après choix dans deux combobox

kinguepat

XLDnaute Nouveau
Bonjour à tous!
J'aimerai s'il vous plait, effectuer une sorte de RechecheV Equiv pour renseigner une TextBox après choix dans deux ComboBox.
Faire en VB ce que le code ci-dessous fait dans les feuilles
VB:
=SIERREUR(RECHERCHEV(Feuil1!C14;Feuil1!A2:G11;EQUIV(Feuil1!C16;Feuil1!B1:G1)+1;0);"")
Merci d'avance pour vos contributions!
 

Fichiers joints

BOISGONTIER

XLDnaute Barbatruc
Bonjour,

VB:
Option Explicit
Private Sub UserForm_Initialize()
  ComboBox1.List = [code].Value
  ComboBox2.Column = [titre].Value
End Sub

Private Sub ComboBox1_click()
  If Me.ComboBox2 <> "" Then affiche
End Sub

Private Sub ComboBox2_click()
  If Me.ComboBox1 <> "" Then affiche
End Sub

Sub affiche()
    Me.TextBox1 = Application.Index([nbres], Me.ComboBox1.ListIndex + 1, Me.ComboBox2.ListIndex + 1)
End Sub
Boisgontier
 

Fichiers joints

Dranreb

XLDnaute Barbatruc
VB:
Option Explicit
Private Sub UserForm_Initialize()
   ComboBox1.List = Feuil1.Range("a2:a11").Value
   ComboBox2.Column = Feuil1.Range("b1:g1").Value
   End Sub
Private Sub ComboBox1_Change()
   RenseignerLabel
   End Sub
Private Sub ComboBox2_Change()
   RenseignerLabel
   End Sub
Private Sub RenseignerLabel()
   Me.TextBox1.Text = Feuil1.[b2].Offset(ComboBox1.ListIndex, ComboBox2.ListIndex).Value
   End Sub
Bonjour.
 

Discussions similaires


Haut Bas