remettre en forme cellule pour obtenir une date suite extraction de données

guillermo

XLDnaute Nouveau
Bonjour à toutes et à tous,

suite à une demande d'extraction et convertion sur excel, j'obtiens une colonne de "date" sous la forme 1040101
1101120
1110308
1110818
1110519

comment puis je faire pour obtenir les vraies dates ?

merci
 

hoerwind

XLDnaute Barbatruc
Re : remettre en forme cellule pour obtenir une date suite extraction de données

Bonjour,

Une date comporte 5, 6 ou 8 chiffres, jamais 7 comme sous ton exemple.
Il y a donc un chiffre en trop, à mon avis le 1 au début.

Souhaites-tu obtenir :
01/01/2004
20/11/2010
08/03/2011
...
ou autre chose ?
 

guillermo

XLDnaute Nouveau
Re : remettre en forme cellule pour obtenir une date suite extraction de données

Bonjour,

oui ça donnerait ça effectivement

Merci pour ton retour
 

hoerwind

XLDnaute Barbatruc
Re : remettre en forme cellule pour obtenir une date suite extraction de données

Re,

Essaie ceci : =DATE(2000+STXT(A1;2;2);STXT(A1;4;2);DROITE(A1;2))
formule à copier vers le bas
 

TempusFugit

XLDnaute Impliqué
Re : remettre en forme cellule pour obtenir une date suite extraction de données

Bonjour

Une autre solution utilisant Données/Convertir
Sélectionnes tes cellules
Faire Données/Convertir : Choisir Largeur Fixe
Mettre le séparateur sur le premier 1
Ensuite pour la colonne 1 , choisir Colonne non distribuée
puis sur l'autre colonne, choisir dans Format des données en colonne: AMJ

La conversion te donnera alors les bonnes dates.

Ce qui donne en VBA (pour aller plus vite)
Code:
Sub Macro5()' macro faite avec l'enregistreur de macro
Selection.TextToColumns Destination:=Range("A1"), DataType:=xlFixedWidth, _
        FieldInfo:=Array(Array(0, 9), Array(1, 5)), TrailingMinusNumbers:=True
End Sub
 
Dernière édition:

Tibo

XLDnaute Barbatruc
Re : remettre en forme cellule pour obtenir une date suite extraction de données

Bonsoir,

Une autre approche, à condition que les années soient postérieures à 2000 :

Code:
=TEXTE("20"&STXT(A1;2;6);"0000-00-00")*1
à mettre au format Date

@+
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas