Autres Relever informations avec critères différents.

CR16

XLDnaute Junior
Bonjour à toutes et à tous,

Je viens vous demander de bien vouloir m'aider à résoudre mon problème.

J'ai 2 onglets, "Listing" et "Tableaux"

Onglet "Listing" il y a 3 colonnes:
"Code" (créé avec une formule)
"Articles" rempli manuellement
"Contenu" rempli manuellement

Onglet "Tableaux" avec plusieurs tableaux identiques, nombre de tableaux non définis.

Après avoir indiquer dans l'entête de chaque tableaux l'article concerné, je voudrais que la cellule sous la colonne "contenu" se remplisse avec la donnée correspondante à la colonne "contenu" de l'onglet "Listing".

Exemples:
tableau "Autres", n°1 du tableau, colonne "contenu" soit indiqué le résultat "1" de l'onglet "Listing
tableau "Divers", n°8 du tableau colonne "contenu" soit indiqué le résultat "26" de l'onglet "Listing"
Etc...

Je partais sur une concaténation entre l'entête du tableau et le numéro de la ligne du même tableau, pour le faire correspondre au code de l'onglet "Listing" et relever l'information obtenue.

Merci d'avance pour vos propositions et n'hésitez pas à me demander des informations.
J'espère avoir bien expliqué mon problème.

Cordialement.

PS: j'ai indiqué dans le fichier avec la couleur rouge et violette les zones cibles.
 

Pièces jointes

  • Tab pour excel.xlsx
    14.1 KB · Affichages: 4

ALS35

XLDnaute Occasionnel
Bonjour,

Effectivement avec une concaténation et RECHERCHEV.
En B3 : =SIERREUR(RECHERCHEV(G$1&G3;Listing!$A$1:$C$29;3;0);"")
à recopier jusqu'à B10 et pour les tableaux Autres et à adapter pour les tableaux Divers et Super.

Cordialement
 

CR16

XLDnaute Junior
Bonjour,

Effectivement avec une concaténation et RECHERCHEV.
En B3 : =SIERREUR(RECHERCHEV(G$1&G3;Listing!$A$1:$C$29;3;0);"")
à recopier jusqu'à B10 et pour les tableaux Autres et à adapter pour les tableaux Divers et Super.

Cordialement
Bonjour,
merci pour la réponse qui me convient bien.
Bonne continuation sur le forum et à une autre occase, ne sait-on jamais.

Excellement
CR16