#ref!

Berg1664

XLDnaute Occasionnel
Bonjour,

j'utilise la fonction LIREDONNEESTABCROISDYNAMIQUE , elle me renvoie parfois #REF! quand elle ne trouve pas ce qu'll' est censé chercher

Mon problème est que ces "REF! m'empèchent de faire des opérations en suites , un quotient ou une simple somme

Ya -il une solution pour supprimer ces #REF! pour pouvoir faire des calculs?

Merci à tous
Cordialement
Berg1664
 

Raja

XLDnaute Accro
Re : #ref!

Bonsoir,

Donne-nous la formule entière qui ramène ce message d'erreur. On tâchera de trouver une solution.
 

ERIC S

XLDnaute Barbatruc
Re : #ref!

Bonjour

a priori d'après l'aide tu pointes là où il n'y a pas de TCD

à essayer

=si(esterreur(LIRE....);"ce que tu veux"; LIRE...)
 

Berg1664

XLDnaute Occasionnel
Re : #ref!

Bonsoir les amis

Je n'arrive pas à appliquer la formule d'ERIC

Je vous joins un petit fichier , ce que je souhaite est dans l'onglet 2

Merci

A+

Berg1664
 

Fichiers joints

job75

XLDnaute Barbatruc
Re : #ref!

Bonsoir à tous,

Quelque chose m'échappe sûrement.

Apparemment le dernier argument de la fonction LIREDONNEESTABCROISDYNAMIQUE est entré manuellement non ?

Alors s'il n'existe pas dans le TCD, pourquoi entrer la formule, puisque l'on sait que ça va créer une erreur ?

A+
 

ERIC S

XLDnaute Barbatruc
Re : #ref!

Bonjour

un exemple en E11

=SI(ESTERREUR(LIREDONNEESTABCROISDYNAMIQUE("CAS pondéré";$A$24;"Code Sous-Objectifs";53;"Libellé Sous-Objectifs";"fraise"));NA();LIREDONNEESTABCROISDYNAMIQUE("CASpondéré";$A$24;"Code Sous-Objectifs";53;"Libellé Sous-Objectifs";"fraise"))

affiche #N/A (pour graphique par exemple) mais tu peux décider de ce que tu veux.
le premier test est sans doute simplifiable (avec un equiv, recherchev...)
 

Berg1664

XLDnaute Occasionnel
Re : #ref!

Bonjour, ta question est pertinente, effectivement le dernier argument est rentré manuellement dans un autre onglet, mais on ne sait pas forcément su la valeur n'existe pas dans le TDD, bien sûr on pourrait aller voir , mais c'est une manip de plu^s...
En fait ce que je voudrais savoir c'est ; comment faire la somme d'une colonne s'il ya au moins un #REF! dans une des cellule de la colonne sans que cela me renvoi #REF!
Sur ce je vai regarder la formule d'Eric
Merci
A+
Cdt
-------------------------------------------------------------------
Bonsoir à tous,

Quelque chose m'échappe sûrement.

Apparemment le dernier argument de la fonction LIREDONNEESTABCROISDYNAMIQUE est entré manuellement non ?

Alors s'il n'existe pas dans le TCD, pourquoi entrer la formule, puisque l'on sait que ça va créer une erreur ?
 

Berg1664

XLDnaute Occasionnel
Re : #ref!

Eric

Ta formule fonctionne et me convient, je remplace #N/A par "0" et je peux faire des calculs

Merci à tous

A+
Cordialement
Berg1664
 

Discussions similaires


Haut Bas