#REF dans une formule si l'onglet référencé n'est pas crée

mirek

XLDnaute Nouveau
Bonjour à tous,

voilà mon soucis j'ai une formule du type
=SI(ESTERREUR(RECHERCHEV(A17;final!F:G;2;0));"";RECHERCHEV(A17;final!F:G;2;0))

"final" étant un onglet du classeur actif qui va etre crée pendant l'application
le problème c'est que dès que l'onglet final est supprimé e que j'ouvre de nouveau le classeur toute mes formules qui font référence à cet onglet m'affiche "#REF" :(

existe t'il un moyen d' éviter cette erreur ?

merci d'avance pour vos réponses et bonne journée

Mirek
 

JeanMarie

XLDnaute Barbatruc
Re : #REF dans une formule si l'onglet référencé n'est pas crée

Bonjour mirek

Code:
=SI(ESTERREUR(RECHERCHEV(A17;INDIRECT("final!F:G");2;0));"";RE CHERCHEV(A17;INDIRECT("final!F:G");2;0));2;0))
INDIRECT transforme une chaîne de caractères représentant une référence de cellule, en une référence compatible avec les formules.
Attentioin, les références de cellules ont une construction ordonnée, ('[]'!) pour la séparation des champs, la représentation texte de la chaîne utilise aussi cette construction.
Ne marche pas sur un classeur fermé.

PS : une autre solution consisterait à masquer dans ton fichier la feuille Final.

@+Jean-Marie
 
Dernière édition:

mirek

XLDnaute Nouveau
Re : #REF dans une formule si l'onglet référencé n'est pas crée

bonjour Jean marie,

merci pour la réponse dès que j'arrive au bureau je fais la modification et je vous tiens au courant.

merci et bonne journée

Mirek
 

mirek

XLDnaute Nouveau
Re : #REF dans une formule si l'onglet référencé n'est pas crée

c'est OK pour moi sa fonctionne à merveille

merci

Mirek
 

Discussions similaires


Haut Bas