recuperer données d'un tableau dans un autre avec condition

GWEN_do_bido

XLDnaute Nouveau
Bonjour à tous,

Je débute et voila plusieurs heures que je tourne en rond sur un problème simple.
J'ai une feuille (linéaire) sur laquelle sont inscrits les horaires des employés, avec leur nom, heure de début de poste et heure de fin, avec le linéaire correspondant

J'ai une autre feuille (horaires) ou j'ai simplement les horaires avec les noms, ou je calcule le total des heures sur la semaine pour chaque personnes.

Je voudrais simplement que la feuille (horaires) se complète automatiquement lorsque je fais des modifications sur la feuille linéaire, pour chaque personne, avec les horaires qui lui ont été attribués

Merci beaucoup
 

Fichiers joints

JCGL

XLDnaute Barbatruc
Bonjour à tous,

Bienvenue sur XLD

Il faut être plus rigoureux avec Excel : cecile est différent de Cécile
Un essai sur le Lundi avec :
Code:
=SOMMEPROD((lineaires!$A$5:$A$25=horaires!A4)*lineaires!$B$5:$B$25)
Je ne vais pas plus loin car la structure du fichier n'est pas adapté...

A+ à tous
 

Fichiers joints

GWEN_do_bido

XLDnaute Nouveau
Merci beaucoup pour votre réponse rapide, elle va vraiment m'aider à avancer.
Effectivement il me faudra être plus attentive à ce genre d'erreur.

a+
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas