Office 365 recuperation des valeurs et en faire la somme dans un autre tableau

manuZ51

XLDnaute Nouveau
Bonsoir,

Je vous expose mon problème et je joins un fichier pour explication. J'ai un onglet report dans lequel se trouve un tableau dont je souhaiterai extraire des données vers un autre onglet graphiques.
je voudrai récupérer la somme qui correspond a deux critères.
Exemple:
Faire la somme des éléments AME dans la colonne Nature associé uniquement des BB dans la colonne Section idem ensuite pour la section UC et cette somme doit être placée dans le tableau graphique en lieu est place de sa somme. si je me suis bien expliqué. J'ai essayé avec SOMME.SI.EN, mais avec deux critères je ne trouve pas la solution ainsi que index associé a equiv mais je n'arrive pas faire la somme je coince

Merci pour votre aide

manu
 

Fichiers joints

manuZ51

XLDnaute Nouveau
Merci pour vos reponses rapides. Dans ma demande j'avais oublie de mentionner un detail important la somme doit se faire sur la colonne Cout et ou durée JHA a anticipé Bravo a tous les deux. je vais mettre tout ça en memoire pour assimiler ces formules et ainsi enrichir mes connaissances .

Merci
 

Staple1600

XLDnaute Barbatruc
Re,

sylvanu
Je vois que tu n'as pas saisi ce dont je parle quand je parle de balise
Sans la balise idoine
=SOMMEPROD((I11:I2000="AME")*(D11:D2000="BBB"))

Avec la balise idoine
=SOMMEPROD((I11:I2000="AME")*(D11:D2000="BBB"))
Sans la balise: :D et avec la balise :D
 

manuZ51

XLDnaute Nouveau
Je vous solicite a nouveau car un nouveau souhait qui ne marche pas j'ai toujours mes données dans l'onglet Report et je voudrai faire la somme par intervenant sur la durée. j'ai un nouveau onglet j'ai essaye somme.prod, somme.si.ens idem rien ne marche en tout cas avec mon niveau

Manu
 

Fichiers joints

JHA

XLDnaute Barbatruc
Bonjour à tous,

A essayer formule matricielle

VB:
=SOMME((ESTNUM(CHERCHE($A11&"*";Report!$D$11:$D$137)))*Report!$M$11:$M$137)
JHA
 

Fichiers joints

manuZ51

XLDnaute Nouveau
Merci JHA j'avais récupéré ta formule en utilisant la forme matricielle mais j'avais enlevé ESTNUM .. c'est excellent trop fort
Merci pour tout et surtout la rapidité a laquelle tu l'as fait

Manu
 

manuZ51

XLDnaute Nouveau
Je vais essayer de trouver un site qui m'explique toutes les formules matricielles possibles :) j'en utilise mais je ne connais pas tout ce que l'on peut faire avec

Manu
 

Littledave59

XLDnaute Nouveau
Dans ta cellule D3 de l'onglet graphique mets cette formule et copie la dans tous le tableau ensuite :

=SOMME.SI.ENS(Report!$M:$M;Report!$I:$I;D$2;Report!$K:$K;$C3&"*")

Solution simple et efficace

David

1577343939278.png
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas