XL 2010 RECHERCHEV

micgca

XLDnaute Junior
Bonjour à tous,
j'utilise la fonction RECHERCHEV qui est très intéressante.

Là ou je butte, c'est que dans ma formule, lorsque je fais glisser la formule aux cellules adjacentes à droite, je voudrais que de M424 on passe à M425 M426 et anisi de suite.
Or, la formule ne change pas et reste sur M424.

PS : vous aurez compris que dans la feuille actuelle, on va rechercher M424 dans une autre feuille PJL.

=SI((PH14="");"";RECHERCHEV(PJL!$M424;Datas1!$A$8:$C$14;3;FAUX))

Merci à tous pour votre aide.
Mic G.
 

natorp

XLDnaute Accro
Bonjour micgca

C'est normal, en tirant vers la droite on ne peut incrémenter que les colonnes

Cordialement, Gérard
 

micgca

XLDnaute Junior
hélas un peu compliqué car confidentiel données clients ; je pensais qu'avec la formule cela suffirait.

je veux juste que l'incrémentation de M424 se fasse sur la même colonne mais avec M425 M426 etc.
Dans cette cellule, (feuille PJL) on met un code, style A B C qui correspondent à un état type ouvert , fermé, en attente etc (les libellés sont dans la feuille DATAS) et RECHERCHEV va inscrire dans la feuille active, le libellé complet correspondant au code A B C.

Je sais, pas facile a expliquer sans classeur exemple.
 

Discussions similaires


Haut Bas