XL 2010 RechercheV pour obtenir id de la région à partir du département

beuzathor

XLDnaute Nouveau
Bonjour,
Je ne trouve pas de solution pour l'utilisation de la formule RECHERCHEV dans mon fichier.
J'ai une base de données avec une table qui contient le nom des régions ainsi que leurs ID.
Et j'ai aussi une autre table qui contient les départements avec la référence à l'id de la region.

Donc pour faire un import dans ma base de données j'ai besoin que mon fichier comprenne le nom de la personne, le numéro de son département ainsi que le numéro de la région liée.
J'ai bien le nom et le numéro du département et pour afficher le numéro de la région j'ai créer deux colonne dans un autre feuillet avec en colonne B le numéro des départements et en colonne A le id de la région.
En suivant la doc sur la fonction recherche j'ai bêtement fait
VB:
=RECHERCHEV(B2;Feuil2!B2:B110;Feuil2!A2:A110)
Mais j'obtiens une jolie erreur #REF !
J'ai bien regardé à droite à gauche mais je ne comprend pas pourquoi la formule ne passe pas.
 

Fichiers joints

Staple1600

XLDnaute Barbatruc
Bonjour

La syntaxe de RECHERCHEV serait plutôt
=RECHERCHEV(B2,Feuil2!$A$2:$B$110;2;0)
2 correspond au numéro de colonne

NB: Il faut inverser les colonnes sur la feuille 2
En colonne A=> dept
En colonne B=> region
 
Dernière édition:

mapomme

XLDnaute Barbatruc
Supporter XLD
Bonjour @beuzathor,
Une fonction recherchev ne peut extraire des données que dans les colonnes à droite de la colonne de recherche.
Essayez plutôt:
VB:
=INDEX(Feuil2!A:A;EQUIV(B2;Feuil2!B1:$B$110;0))
edit: bonjour @Staple1600 :cool:
 

Staple1600

XLDnaute Barbatruc
Bonjour mapomme

Zut, si t'avais posté un peu plutôt, j'aurai pas eu à inverser les colonnes en feuille 2 ;)
 

Discussions similaires


Haut Bas